[gmx-developers] CVS implementation of REMD

Ken Rotondi ksr at chemistry.umass.edu
Thu May 26 14:41:22 CEST 2005

On May 25, 2005, at 11:19 AM, Anton Feenstra wrote:

> Ken Rotondi wrote:
>> Then I ran mdrun:
>> mdrun -v -multi -np 2 -replex 20 -s topol.tpr
> Perhaps -np 2 and -replex 20 'bite' each other. From what I gather 
> from the other mails, 'mdrun -v -multi -replex 2' could work.
> -- 
> Groetjes,
> Anton

This is rather confusing. I thought the -np flag was for the number of 
processes running (i.e. the number of replicas in a REMD run) while the 
-replex flag defines the number of integration steps that pass between 
attempts at exchange.

I'm still hopeful for insight into this problem and am re-posting the 
question in response to several helpful suggestions:

Thanks for the suggestions. I'm probably doing more than two things 

Okay, I used grompp to generate sequentially numbered .tpr files using:

grompp -v -f 1.mdp -po 1out.mdp -c md8.gro -p p39a.top -o topol0.tpr

grompp -v -f 2.mdp -po 2out.mdp -c md8.gro -p p39a.top -o topol1.tpr

where 1.mdp and 2.mdp are .mdp files for adjacent temperatures in a 
REMD analysis I am setting up.

Then I ran mdrun:

mdrun -v -multi -np 2 -replex 20 -s topol.tpr


Can not open file:

So I tried

mdrun -v -multi -np 2 -replex 20

same result.

Help, please.


More information about the gromacs.org_gmx-developers mailing list