[gmx-developers] block_tx.c error on 3.3_rc3

Yiannis ioannis.nicolis at free.fr
Tue Oct 4 02:07:29 CEST 2005

I try to run in parallel between two different machines, both dual 
Xeon, one is 2x2.8GHz i686 with Mandrake, the other is 2x3.2GHz x86_64 
with Suse.
Is it possible to run on the 4 CPUs?
After reading the thread on the list I installed the 3.3_rc3 tarball 
but when I try:

grompp -v -np 4
mpirun -v -np4 mdrun_mpi -v -np 4

on the d.villin benchmark I get the block_tx.c error:

Reading file topol.tpr, VERSION 3.3_rc3 (single precision)
Program mdrun_mpi, VERSION 3.3_rc3
Source code file: block_tx.c, line: 74

Fatal error:
0: size=672, len=840, rx_count=0


I tried to run on two CPU on the same machine, it works with no 
problem, I tried also to run on two CPUs, one in each machine and I 
then have the same block_tx error.

So, is the problem coming from the heterogeneous environment and I 
should stop trying, or it is supposed to work and in that case how?

Thanks for any help,

Ioannis Nicolis

More information about the gromacs.org_gmx-developers mailing list