[gmx-developers] GDB Debugging - GROMACS(v-3.3.3) Application with OpenMPI(v-1.2.5/v-1.2.6)

Daniel Larsson larsson at xray.bmc.uu.se
Thu Apr 17 22:08:35 CEST 2008

On Apr 17, 2008, at 19:36, Mukesh K Srivastava wrote:
> Hi.
> Anyone had performed GDB debugging for Gromacs(v3.x - v3.3.3)  
> application with FFTW(v3.1) using OpenMPI(v-1.2.5 or v-1.2.6). I  
> had properly configured OpenMPI with debug option and also  
> configured Gromacs alongwith FFTW succesfully. I can perform  
> p2bdbx_mpi, editconf_mpi, genbox_mpi, grompp_mpi compilation and  
> finally mdrun_mpi without any error or warning messages. But while  
> executing mdrun_mpi w.r.t mprun, I get libmpi.so.0 not found.

This is probably not really any help but just to clarify, as far as I  
know, only mdrun can be run in parallel.

>  I had tried with LD_LIBRARY_PATH, forcefully mentioning PATH &  
> LD_LIBRARY_PATH in etc/bashrc file and also tried with providing  
> softlink to libmpi.so.0, but everytime I get same error message of  
> "libmpi.so.0" not found.
> I had check ldd and it's dependency of executable mdrun_mpi,  
> checked it's symbol table content, and finally all lib's configured  
> for 64 bit with ELF format but still getting same error of  
> libmpi.so.0 not found while performing GDB serial debugging with  
> single node.
> Note: I had performed GDB debugging for small MPI program(hello  
> world) using OpenMPI(v1.2.5/v1.2.6) wthout GROMACS association  
> succesfully.
> Any clue plz?
> BR
> _______________________________________________
> gmx-developers mailing list
> gmx-developers at gromacs.org
> http://www.gromacs.org/mailman/listinfo/gmx-developers
> Please don't post (un)subscribe requests to the list. Use the
> www interface or send it to gmx-developers-request at gromacs.org.


Daniel Larsson
Molecular Biophysics group
Department of Cell and Molecular Biology
Uppsala University

+46-18-471 4006 (phone)
+46-18-511 755  (fax)
larsson at xray.bmc.uu.se

More information about the gromacs.org_gmx-developers mailing list