[gmx-developers] MPI_ERR_COMM on 4.5.5-patches

Alexander Schlaich alexander.schlaich at fu-berlin.de
Tue Aug 28 19:39:49 CEST 2012

Dear Gromacs team,

I just tried to install the release-4.5.5_patches branch with --enable-mpi on our cluster (OpemMPI-1.4.2), resulting in an error when calling mdrun whith pme enabled:

Reading file topol.tpr, VERSION 4.5.5-dev-20120810-2859895 (single precision)
[sheldon:22663] *** An error occurred in MPI_comm_size
[sheldon:22663] *** on communicator MPI_COMM_WORLD
[sheldon:22663] *** MPI_ERR_COMM: invalid communicator
[sheldon:22663] *** MPI_ERRORS_ARE_FATAL (your MPI job will now abort)

This seems to be related to a recent post on the list, however I could not find a solution:
However, the 4.5.5 release version works fine.

Taking a closer look I found commit dcf8b67e2801f994dae56374382b9e330833de30, "changed PME MPI_Comm comparisions to MPI_COMM_NULL, fixes #931" (Berk Hess). Apparently here the communicators were changed such that the initialization fails on my system. Reverting this single commit on the head of the release-4.5.5 branch solved the issue for me.

As I am no MPI expert I would like to know if my MPI implementation is misbehaving here, if I made a configuration mistake or if I should file a bug report?

Thanks for your help,


Alexander Schlaich
FU Berlin, Fachbereich Physik,
AG Netz  (room 0.3.31)
Phone (++49|0) 30-838-54575
Arnimallee 14
14195 Berlin, Germany

More information about the gromacs.org_gmx-developers mailing list