[gmx-developers] Minor CMAKE/fftw3 problem VS2010 x64 - finally solved

Mirco Wahab mirco.wahab at chemie.tu-freiberg.de
Tue Feb 28 14:49:05 CET 2012

Hi Roland,

Am 28.02.2012 01:34, schrieb Roland Schulz:
> OK. That explains it. I took the fftw precompiled from
> http://www.fftw.org/install/windows.html and it has the #define FFTW_DLL
> not commented out.

In the mean time, I prepared a rar archive containing
DCMAKE_PREFIX_PATH files that don't require any #defines
and leads to successful compilation.

What about  -DGMX_GPU=ON in 4.6? I had the impression
this would be there? For this, I prepared a windows
machine with CUDA.

BTW, I solved the problems w/windows git & ssh (there was an
interference to Tortoise git, which had setup some environment
variables irritating mingw ssh)

But I can't push my two small changes (compilation w/VS2010
when GSL enabled) to gerrit, I dont know why. This is
the sequence I performed:

git clone ssh://mwah@gerrit.gromacs.org:29418/gromacs.git
cd gromacs
git remote set-url origin ssh://mwah@gerrit.gromacs.org:29418/gromacs.git
git checkout --track -b release-4-6 origin/release-4-6
scp -p -P 29418 mwah at gerrit.gromacs.org:hooks/commit-msg .git/hooks/


patch -p0 < ../../support/win.4.6-dev-20120226.diff


devenv ...

[push changes]

$ git push
Enter passphrase for key '/c
Everything up-to-date

2) git push origin HEAD:refs/for/release-4-6
$ git push origin HEAD:refs/for/release-4-6
Enter passphrase for key '/c/Users/aqqag/.ssh/id_rsa':
Total 0 (delta 0), reused 0 (delta 0)
To ssh://mwah@gerrit.gromacs.org:29418/gromacs.git
  ! [remote rejected] HEAD -> refs/for/release-4-6 (no new changes)
error: failed to push some refs to 

Hmmm ...

Is this remote now? I can't see it.

Thank you very much for your help


More information about the gromacs.org_gmx-developers mailing list