[gmx-developers] feedback wanted: dropping CUDA 3.2/4.0 support

Szilárd Páll pall.szilard at gmail.com
Sun Dec 1 23:11:44 CET 2013


In order to ease the maintenance of the native GPU/acceleration in
GROMACS, we are removing support for CUDA versions 3.2 and 4.0 in the
next version (5.0).

We have two options:

- Limit the change to performance impact on the GPU kernels due to the
removal of the legacy kernels, but do not prevent compilation with
CUDA 3.2/4.0.

- Require CUDA 4.1 or later; compilation with v3.2/v4.0 and therefore
running with any driver earlier than 285.05 will not be possible. Note
that we would prefer this option to be able to (unconditionally) use
certain CUDA features introduced after 3.2/4.0.

To conclude:

- FYI: to those stuck with old CUDA/driver, unless you update CUDA (if
you can) you may have issues when compiling v5.0;

- Question: if you have any reasonable objections against he GROMACS
v5.0 installer *requiring* at least CUDA 4.1, please voice your
opinion on this short poll: http://goo.gl/v5iE2b

Please express your opinions (both for/against the deprecation) ASAP!
Comments and suggestions are, as always, welcome.


More information about the gromacs.org_gmx-developers mailing list