[gmx-developers] Compiling analysis tool with GROMACS 5

Ondrej Marsalek ondrej.marsalek at gmail.com
Fri Aug 14 08:52:42 CEST 2015

Hi Teemu,

thank you for the suggestion, that fixed it. I was trying to follow
what the standard GROMACS tools do, but could not quite figure out
this bit, as they all get called through the single gmx executable
infrastructure. It actually solved the problem with the library path
as well.

Thank you,

On Thu, Aug 13, 2015 at 8:09 PM, Teemu Murtola <teemu.murtola at gmail.com> wrote:
> On Fri, Aug 14, 2015 at 1:24 AM Ondrej Marsalek <ondrej.marsalek at gmail.com>
> wrote:
>> However, I lost the ability to get the documentation using the -h
>> option. Other common arguments, like -b and -e, work fine (I give
>> PCA_CAN_TIME to parse_common_args). Is there some obvious change in
>> version 5 that I am missing that is causing this, or do I need to dig
>> deeper?
> You need to use gmx_run_cmain() as a wrapper around your old main()
> function. And you need to respect the return value of parse_common_args() if
> you didn't yet do that change.
>> Another problem is that where I was previously (with 4.6) able
>> to provide a .tpr and only optionally an .ndx, if I now only give a
>> .tpr, the program fails with:
>> -------------------------------------------------------
>> Program GROMACS, VERSION 5.0.2
>> Source code file:
>> /home/marsalek/build/gromacs-5.0.2/src/gromacs/fileio/futil.cpp, line:
>> 790
>> Fatal error:
>> Library file residuetypes.dat not found in current dir nor in default
>> directories.
>> (You can set the directories to search with the GMXLIB path variable)
>> For more information and tips for troubleshooting, please check the
>> website at http://www.gromacs.org/Documentation/Errors
>> -------------------------------------------------------
>> when get_index is called. If I copy residuetypes.dat to the working
>> directory, the tool runs fine. Other GROMACS tools also work as
>> expected.
> When you start using gmx_run_cmain(), the tool will by default also print
> out  the library directory from where it looks for residuetypes.dat. That
> may help diagnosing the issue, but not knowing your directory structure or
> the way you compiled/installed Gromacs or your tool, I can't immediately
> suggest any possible reason.
> Best regards,
> Teemu
> --
> Gromacs Developers mailing list
> * Please search the archive at
> http://www.gromacs.org/Support/Mailing_Lists/GMX-developers_List before
> posting!
> * Can't post? Read http://www.gromacs.org/Support/Mailing_Lists
> * For (un)subscribe requests visit
> https://maillist.sys.kth.se/mailman/listinfo/gromacs.org_gmx-developers or
> send a mail to gmx-developers-request at gromacs.org.

More information about the gromacs.org_gmx-developers mailing list