[gmx-developers] Problem inserting protein to membrane during InflateGro

Robert Nairn rn33 at st-andrews.ac.uk
Wed Oct 18 19:22:58 CEST 2017

Dear all,

I am currently trying to insert the MscL protein into the DMPC bilayer. I
followed Justin Lemkul's tutorial 2 (with the exception of using dmpc
instead of dppc) and receive this error message after shrinking and energy

[christos at chpc-cp39 Simulation]$ gmx mdrun -v -deffnm em
                   :-) GROMACS - gmx mdrun, VERSION 5.1.4 (-:

                            GROMACS is written by:
     Emile Apol      Rossen Apostolov  Herman J.C. Berendsen    Par
 Aldert van Buuren   Rudi van Drunen     Anton Feenstra   Sebastian Fritsch
  Gerrit Groenhof   Christoph Junghans   Anca Hamuraru    Vincent Hindriksen
 Dimitrios Karkoulis    Peter Kasson        Jiri Kraus      Carsten
    Per Larsson      Justin A. Lemkul   Magnus Lundborg   Pieter Meulenhoff
   Erik Marklund      Teemu Murtola       Szilard Pall       Sander Pronk
   Roland Schulz     Alexey Shvetsov     Michael Shirts     Alfons Sijbers
   Peter Tieleman    Teemu Virolainen  Christian Wennberg    Maarten Wolf
                           and the project leaders:
        Mark Abraham, Berk Hess, Erik Lindahl, and David van der Spoel

Copyright (c) 1991-2000, University of Groningen, The Netherlands.
Copyright (c) 2001-2015, The GROMACS development team at
Uppsala University, Stockholm University and
the Royal Institute of Technology, Sweden.
check out http://www.gromacs.org for more information.

GROMACS is free software; you can redistribute it and/or modify it
under the terms of the GNU Lesser General Public License
as published by the Free Software Foundation; either version 2.1
of the License, or (at your option) any later version.

GROMACS:      gmx mdrun, VERSION 5.1.4
Executable:   /usr/local/gromacs/bin/gmx
Data prefix:  /usr/local/gromacs
Command line:
  gmx mdrun -v -deffnm em

Back Off! I just backed up em.log to ./#em.log.7#

Running on 1 node with total 4 cores, 4 logical cores
Hardware detected:
  CPU info:
    Vendor: GenuineIntel
    Brand:  Intel(R) Core(TM) i5-4460  CPU @ 3.20GHz
    SIMD instructions most likely to fit this hardware: AVX2_256
    SIMD instructions selected at GROMACS compile time: AVX2_256

Reading file em.tpr, VERSION 5.1.4 (single precision)
Using 1 MPI thread
Using 4 OpenMP threads

Back Off! I just backed up em.trr to ./#em.trr.7#

Back Off! I just backed up em.edr to ./#em.edr.7#

Steepest Descents:
   Tolerance (Fmax)   =  1.00000e+03
   Number of steps    =        50000
Step=    0, Dmax= 1.0e-02 nm, Epot= -3.20786e+05 Fmax= 1.71766e+03, atom=
Step=    2, Dmax= 5.0e-03 nm, Epot= -3.22206e+05 Fmax= 2.42847e+03, atom=
Step=    3, Dmax= 6.0e-03 nm, Epot= -3.22537e+05 Fmax= 5.33224e+03, atom=
Step=    4, Dmax= 7.2e-03 nm, Epot= -3.23803e+05 Fmax= 3.73628e+03, atom=
Step=    6, Dmax= 4.3e-03 nm, Epot= -3.24377e+05 Fmax= 1.77965e+03, atom=
Step=    7, Dmax= 5.2e-03 nm, Epot= -3.24696e+05 Fmax= 4.72325e+03, atom=
Step=    8, Dmax= 6.2e-03 nm, Epot= -3.25203e+05 Fmax= 3.21307e+03, atom=
Step=   10, Dmax= 3.7e-03 nm, Epot= -3.25578e+05 Fmax= 1.53786e+03, atom=
Step=   11, Dmax= 4.5e-03 nm, Epot= -3.25794e+05 Fmax= 4.19745e+03, atom=
Step=   12, Dmax= 5.4e-03 nm, Epot= -3.26199e+05 Fmax= 2.65229e+03, atom=
Step=   14, Dmax= 3.2e-03 nm, Epot= -3.26475e+05 Fmax= 1.44458e+03, atom=
Step=   15, Dmax= 3.9e-03 nm, Epot= -3.26646e+05 Fmax= 3.51711e+03, atom=
Step=   16, Dmax= 4.6e-03 nm, Epot= -3.26945e+05 Fmax= 2.42357e+03, atom=
Step=   18, Dmax= 2.8e-03 nm, Epot= -3.27174e+05 Fmax= 1.16101e+03, atom=
Step=   19, Dmax= 3.3e-03 nm, Epot= -3.27357e+05 Fmax= 3.10626e+03, atom=
Step=   20, Dmax= 4.0e-03 nm, Epot= -3.27599e+05 Fmax= 2.04763e+03, atom=
Step=   21, Dmax= 4.8e-03 nm, Epot= -3.27618e+05 Fmax= 4.11224e+03, atom=
Step=   22, Dmax= 5.8e-03 nm, Epot= -3.27866e+05 Fmax= 3.29947e+03, atom=
Step=   24, Dmax= 3.5e-03 nm, Epot= -3.28131e+05 Fmax= 1.11942e+03, atom=
Step=   25, Dmax= 4.2e-03 nm, Epot= -3.28185e+05 Fmax= 4.23073e+03, atom=
Step=   26, Dmax= 5.0e-03 nm, Epot= -3.28509e+05 Fmax= 2.13723e+03, atom=
Step=   28, Dmax= 3.0e-03 nm, Epot= -3.28653e+05 Fmax= 1.71455e+03, atom=
Step=   29, Dmax= 3.6e-03 nm, Epot= -3.28732e+05 Fmax= 2.86474e+03, atom=
Step=   30, Dmax= 4.3e-03 nm, Epot= -3.28867e+05 Fmax= 2.67060e+03, atom=
Step=   31, Dmax= 5.2e-03 nm, Epot= -3.28877e+05 Fmax= 3.93851e+03, atom=
Step=   32, Dmax= 6.2e-03 nm, Epot= -3.28983e+05 Fmax= 4.01820e+03, atom=
Step=   34, Dmax= 3.7e-03 nm, Epot= -3.29290e+05 Fmax= 7.22653e+02, atom=

writing lowest energy coordinates.

Back Off! I just backed up em.gro to ./#em.gro.7#

Steepest Descents converged to Fmax < 1000 in 35 steps
Potential Energy  = -3.2929012e+05
Maximum force     =  7.2265314e+02 on atom 889
Norm of force     =  7.2922180e+01

NOTE: 20 % of the run time was spent in pair search,
      you might want to increase nstlist (this has no effect on accuracy)

gcq#490: "I have a hunch that the unknown sequences of DNA will decode into
copyright notices and patent protections." (Donald Knuth)

[christos at chpc-cp39 Simulation]$ perl inflategro.pl em.gro 0.95 DMPC 0
system_shrink1.gro 5 area_shrink1.dat
Scaling lipids....
There are 128 lipids...
with 46 atoms per lipid..

Determining upper and lower leaflet...
64 lipids in the upper...
64 lipids in the lower leaflet

No protein coordinates found...
Writing scaled bilayer & centered protein...

Calculating Area per lipid...
Protein X-min/max: 10000    -9999
Protein Y-min/max: 10000    -9999
X-range: -19999 A    Y-range: -19999 A
Building -19999 X -19999 2D grid on protein coordinates...
Calculating area occupied by protein..
full TMD..
upper TMD..
lower TMD..
Area per protein: 0 nm^2
Area per lipid: 0.53787556 nm^2

Area per protein, upper half: 0 nm^2
Area per lipid, upper leaflet : 0.53787556 nm^2

Area per protein, lower half: 0 nm^2
Area per lipid, lower leaflet : 0.53787556 nm^2

Writing Area per lipid...

I've also tried the same process with popc and dppc and get the same error
message. I've previously read that it could be an issue with the grompp
coordinate input file, but I'm not sure what is wrong in this instance.


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://maillist.sys.kth.se/pipermail/gromacs.org_gmx-developers/attachments/20171018/b235e9d6/attachment-0001.html>

More information about the gromacs.org_gmx-developers mailing list