<div dir="ltr">Hi Mirco,<div><br></div><div>I got local access to a machine with two AMD GPUs, and ran into the same initialization issues I&#39;d seen with Nvidia runtimes, so I have updated¬†<a href="https://gerrit.gromacs.org/4314">https://gerrit.gromacs.org/4314</a> so that in 5.1 GROMACS will never use more than one OpenCL device per node. We can probably fix that in the longer term, but it seems like issues of host-side concurrency are not treated in the OpenCL standard (or at least the implementations we&#39;ve targeted), and we didn&#39;t do a good enough job of anticipating and managing that.</div><div><br></div><div>However, being able to use one AMD GPU per node is still a very good thing, and confirmation that seems to work for you would be great!</div><div><br></div><div>Thanks,</div><div><br></div><div>Mark</div><br><div class="gmail_quote"><div dir="ltr">On Mon, Jun 22, 2015 at 8:55 PM Mirco Wahab &lt;<a href="mailto:mirco.wahab@chemie.tu-freiberg.de">mirco.wahab@chemie.tu-freiberg.de</a>&gt; wrote:<br></div><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">On 22.06.2015 20:40, Mark Abraham wrote:<br>
&gt; ... forgetting to commit matching changes to the code. Roland&#39;s fixed some<br>
&gt; MSVC issues, and the gmx_wham #include issue is also merged. The one<br>
&gt; thing we don&#39;t have the ability to test locally is a run with two<br>
&gt; domains, each on separate AMD GPU (because we only have one, so far!) so<br>
&gt; if you have been / are able to test that case, that would be very<br>
&gt; welcome. <a href="https://gerrit.gromacs.org/#/c/4314/" rel="noreferrer" target="_blank">https://gerrit.gromacs.org/#/c/4314/</a> is based on all the fixes<br>
&gt; so far.<br>
<br>
I&#39;m back at my AMD-box on thursday evening european time and will<br>
test the changes immediately - and post the results then.<br>
<br>
Regards<br>
<br>
M.<br>
<br>
<br>
</blockquote></div></div>