[gmx-users] MPICH hang

David van der Spoel spoel at xray.bmc.uu.se
Thu Dec 20 20:40:13 CET 2001

On Thu, 20 Dec 2001, Mehmet Suezen wrote:

>I have tried to compile with MPICH implementation of MPI and obtained
>executable successfully.(called mdrun_mpi_d
>Water sample simulation of gromacs works fine with single processor like
>mpirun -np 1 -machinefile file_hosts mdrun_mpi_d -s water.tpr -o
>water.trr -c water_out.gro -v -g water.log
>where file_hosts is simply hosts.
>But If I tried with -np 2 or more than it seems that program hanged
>after MPI_init().I have noticed this in user guide of  
>MPICH .I`m attaching echo of mpirun in case of -np 2.
did you run grompp -np 2?
check your md0.log file
otherwise can mdrun find the mpi libraries (in the case of shared
libraries you may have to set LD_LIBRARY_PATH environment variable)

Groeten, David.
Dr. David van der Spoel, 	Biomedical center, Dept. of Biochemistry
Husargatan 3, Box 576,  	75123 Uppsala, Sweden
phone:	46 18 471 4205		fax: 46 18 511 755
spoel at xray.bmc.uu.se	spoel at gromacs.org   http://zorn.bmc.uu.se/~spoel

More information about the gromacs.org_gmx-users mailing list