[gmx-users] Still no joy - Cannot run in parallel

Alan Wilter Sousa da Silva alan at biof.ufrj.br
Wed Sep 5 18:37:38 CEST 2001

Hi Dr. Spoel,

	Well, I tried what you said, but ... :(, I got:

mpirun  -c 2 -c2c -O mdrun_mpi -s water.tpr -o water.trr  -c
water_out.gro -v -g water.log -np 2

mpirun: cannot start mdrun_mpi on n1: No such file or directory

	So, reading a little bit, I made some changes...:

mpirun  -c 2 -c2c -O -v -s n0 mdrun_mpi -s water.tpr -o w ater.trr
-c water_out.gro -v -g water.log -np 2

18439 mdrun_mpi running on n0 (o)
993 mdrun_mpi running on n1
mdrun_mpi: error while loading shared libraries: libmd_mpi.so.1: cannot
load shared object file: No such file or directory
It seems that [at least] one of processes that was started with mpirun
did not invoke MPI_INIT before quitting (it is possible that more than
one process did not invoke MPI_INIT -- mpirun was only notified of the
first one, which was on node n0).

mpirun can *only* be used with MPI programs (i.e., programs that
invoke MPI_INIT and MPI_FINALIZE).  You can use the "lamexec" program
to run non-MPI programs over the lambooted nodes.

Giving more details about my cluster.  I installed lam in every node.  The
others nodes just have a HD, no keyboard, no video.

I'm using MOSIX.  I would expect mdrun_mpi to share itself in several
jobs, so MOSIX could take care of every job.  With MPI, as I realize now,
MOSIX wouldn't be necessary.

My LAM is working fine (I guess), so what more can I do, please?

On Wed, 5 Sep 2001, David van der Spoel wrote:

> On Wed, 5 Sep 2001, Alan Wilter Sousa da Silva wrote:
> >Hi!
> >
> >	I took the tutorial "water" to test a simulation in parallel.  I
> >set a cluser of 4 processors using MOSIX architecture.  I put all
> >libraries necessary (I guess), I started lamboot.  So I did:
> >>grompp -f water.mdp -p water.top -c spc216.gro -o water.t pr -np 2
> >-shuffle -sort
> >(to test a simulation using 2 processors)
> >Then:
> >>mdrun_mpi -s water.tpr -o water.trr -c water_out.gr o -v -g
> >water.log -np 2
> you should type
> mpirun -c 2 -c2c -O mdrun_mpi options...

Alan Wilter S. da Silva
 Laboratório de Física Biológica
  Instituto de Biofísica Carlos Chagas Filho
   Universidade do Brasil/UFRJ
    Rio de Janeiro, Brasil

More information about the gromacs.org_gmx-users mailing list