[gmx-users] (no subject)

Christopher Yip christopher.yip at utoronto.ca
Tue Dec 31 14:58:47 CET 2002

>    I tried to installed gromacs-3.1.4 over a mac with OSX.2.  When 
>running make
>I gut:
>./../include/ppc_altivec.h: In function `set_non_java_mode':
>./../include/ppc_altivec.h:60: argument 0 to built-in function `vec_splat_u32'
>does not satisfy constraint A
>make[3]: *** [fnbf.lo] Error 1
>make[2]: *** [all-recursive] Error 1
>make[1]: *** [all] Error 2
>make: *** [all-recursive] Error 1
>does someone know how to overcome it?  I used "bin/bash ./configure" at the
>begining.  I add the log file I produced from the make script.
>   Thanks, Kass.
>| Itamar Kass
>| The Alexander Silberman
>| Institute of Life Sciences
>| Department of Biological Chemistry
>| The Hebrew University, Givat-Ram
>| Jerusalem, 91904, Israel
>| Tel: +972-(0)2-6585146
>| Fax: +972-(0)2-6584329
>| Email: ikass at vms.huji.ac.il
>| Group Homepage: http://www.ls.huji.ac.il/~membranelab/
>Content-Type: application/octet-stream; name="make.log"
>Content-Disposition: attachment; filename="make.log"
>Attachment converted: Macintosh HD:make.log (????/----) (0012CB42)

Have you tried the newer one - 3.1.5-pre_1?. That might work better - 
it's supposed to be more-Altivec friendly.

You can get it from the Gromacs FTP site in the beta section

That's what we're using

Christopher M. Yip, Ph.D., P.Eng.
Associate Professor - Canada Research Chair in Molecular Imaging
Department of Chemical Engineering and Applied Chemistry
Institute of Biomaterials and Biomedical Engineering
Department of Biochemistry
University of Toronto
407 Rosebrugh Building, 4 Taddle Creek Rd.
Toronto, Ontario CANADA M5S 3G9
Office:(416) 978-7853; Lab:(416) 946-5022; Fax: (416) 978-4317;
e-mail: christopher.yip at utoronto.ca
WWW: http://bigten.ibme.utoronto.ca

More information about the gromacs.org_gmx-users mailing list