[gmx-users] g_disre and multiple tpb-file

Paul Czodrowski pc at rufus.biomed.brown.edu
Tue Jul 9 22:23:00 CEST 2002

Hi David,
Dear Gromacs-Community,

> > I ran a MD on 3 processors with distance restraints and now I want to take
> > a look at the violations of my restraints. For this purpose, g_disre seems
> > to be the best choice.
> > When I run g_disre, I get the following error message:
> > "run input file full_index.tpb was made for 3 nodes, while g_disre
> > expected it to be for 1 nodes."
> >
> > Then I try to convert my tpb-file via tpbconv, but again I get an error
> > message or more exactly the computer dumps a core file. I also tried the
> > switch -unconstrained (although it is the default...) but nothing changed.
> try making a tpr file for 1 cpu using grompp

I used grompp in the following way:
grompp -f full_31.mdp -c full_index.tpb -o full_concat.tpb -v -n index.ndx

Whereas full_index.tpb is the tpb-file for multiple processors. The grompp
went fine, but when I ran
g_disre -s full_concat.tpb -f traj_index.xtc -ds drsum.xvg -dr restr.xvg

I got the error message:
Reading file full_concat.tpb, VERSION 3.1.3 (single precision)
Reading file full_concat.tpb, VERSION 3.1.3 (single precision)
Reading frame       0 time    0.000   Segmentation fault (core dumped)

Where could be the error?


More information about the gromacs.org_gmx-users mailing list