[gmx-users] Problems running in paralell on IBM SP

Erik Lindahl lindahl at stanford.edu
Sat Mar 9 03:04:04 CET 2002

"David L. Bostick" wrote:

> Hi Erik,
> Thanks for the response on the IBM.  Let me be more specific.  The SP I use
> has 32 bit mpi.  I did the following because I kept getting errors
> pertaining to "large files":
> setenv CC xlc
> setenv CFLAGS "-O3 -bmaxdata:2147483648 -I/gpfs/dbostick/fftw/include"
> setenv CPPFLAGS -I/gpfs/dbostick/fftw/include
> setenv F77 mpxlf
> setenv FFLAGS "-O3 -bmaxdata:2147483648 -I/gpfs/dbostick/fftw/include"
> setenv LDFLAGS  "-L/gpfs/dbostick/fftw/lib -L/usr/local/lib
>         -bmaxdata:2147483648"
> Then I ran configure like,
> ./configure --enable-mpi --prefix=/gpfs/dbostick/gmx-3.1
> --disable-largefile --program-suffix="_mpi"
> Then make mdrun, make install-mdrun.
> The fftw libraries were installed using the same variables.
> The non-mpi stuff seems to have compiled fine.  A few notes however:
> I have a test system that worked in my version of gmx-2.0 that is basically
> a 4-helix alamethicin bundle in a hydrated POPC bilayer.
> 1) The tutorial of 216 spc waters in a box works with the mpi gmx-3.1 I
> compiled as above.
> 2) The test POPC/alamethecin system does not work.  The log files are
> started, but standard error gives,
> ERROR: 0031-250  task 5: Segmentation fault
> ERROR: 0031-250  task 6: Segmentation fault
> ERROR: 0031-250  task 4: Segmentation fault

Hi David,

I think I just might have found something; in the latest version of the GNU
config.guess (that comes with gromacs 3.1) my IBM system is now detected as


instead of


This could interfere with the detection script for optimization flags... What
kind of system does the configure script say you have, and what compiler flags
does it use?



More information about the gromacs.org_gmx-users mailing list