[gmx-users] [v3.1.3] Failed to create Makefile

Meng-Juei Hsieh mjhsieh at yahoo.com
Mon May 6 21:23:32 CEST 2002

Erik Lindahl Wrote:
> Meng-Juei Hsieh wrote:
>> I just downloaded the gromacs 3.1.3, tried to configure it but failed. It is
>> a known issue here? It worked in 3.1.2.
>> I am using MacOS X with gcc.
> Hi,
> It's because /bin/sh on OS X is zsh and not bash - this isn't a
> gromacs-specific problem, but it appears for almost all autoconf-based
> programs. ( I don't think 3.1.2 worked either, but I haven't tried it
> myself!)
> Just install the bash shell and run "/path/to/bash ./configure"
> Cheers,
> Erik

Dear Erik,
Thanks! It works right now.

By the way, I found there is a problem with OS X's new gcc3.1.
fnbf.c: In function `set_non_java_mode':
fnbf.c:60: argument 0 to built-in function `vec_splat_u32' does not satisfy
constraint A
make[3]: *** [fnbf.lo] Error 1
make[2]: *** [all-recursive] Error 1
make[1]: *** [all] Error 2
make: *** [all-recursive] Error 1

It works if I use gcc2.95, I think I will stick on it until Apple gcc3.1 is
no longer an experimental release.


More information about the gromacs.org_gmx-users mailing list