[gmx-users] lam and dual pentium box

sschirm at student.ethz.ch sschirm at student.ethz.ch
Mon Nov 25 14:02:56 CET 2002

Hello gmx people,

I have troubles running a parallel MD-Run on a single Pentium dual box
running Linux (SuSE). Maybe someone used the same setup as i do or at 
least a setup close to it. 


(the lam version from the gromacs page wasn't available anymore.)

fftw-2.1.3-2.i386.rpm and  fftw-lammpi-2.1.3-2.i386.rpm
(as recommended)

gromacs-3.1.4-1.i386.rpm and gromacs-mpi-3.1.4-1.i386.rpm

Everything runs fine using mdrun (gmxdemo). Then i tried to get both 
processors working. I startet lam using lamboot, which resulted in the 
following output looking perfectly adequate:

LAM 6.5.8/MPI 2 C++/ROMIO - Indiana University
Executing hboot on n0 (localhost - 2 CPUs)...
topology done

Then I grabbed a part out of the gmxdemo, and addapted it for parallel 
run. I considered the parameter globbing problem occuring when using 
mdrun_mpi with mpirun, as mentioned in other posts.

mpirun C mdrun_mpi -np 2 -s cpeptide_md -o cpeptide_md -c
cpeptide_after_md -v

This resulted in no output at all, and a crash of lam deamon. I tried it
times, booting lam again, with different parameters to mpirun, as -c 2,
or -np 2
without success...

Any hints or notes are highly welcome!


More information about the gromacs.org_gmx-users mailing list