[gmx-users] compiling problem on alpha-cluster, ld?

Fan Hao F.Hao at chem.rug.nl
Wed Oct 2 12:11:51 CEST 2002

Hi, all:

    I met problems when I tried to install gmx3.0

on our alpha cluster (MACHTYPE=alpha;  OSTYPE=linux).

At first, the installation was fine but it gave:

"error in loading shared libraries: libXext.so.6 ..."

Then I tried to recompile gmx without x support.

I guess: --without-motif-libraries could be the right choice

and I also include system libraries by adding "/etc/ld.so.conf"

into $path of my .cshrc file. What I did was :

"  ./configure --prefix=/home/gmx/home3.0 --enable-mpi

 --enable-x86-asm --without-motif-libraries

   make                                     "

It provided the following message:

"/opt/binutils-2.13/bin/ld: grompp:

Not enough room for program headers (allocated 6, need 7)

/opt/binutils-2.13/bin/ld: final link failed: Bad value "

I am not sure what it means. Should I change my enviroment

or change the Makefile? Any hints are sincerely appreciated!!!

Best regards

Yours sincerely

Hao Fan :-)

Drs. Hao Fan                            email F.Hao at chem.rug.nl
Lab. of Biophysical Chemistry
University of Groningen
Nijenborgh 4                            9747 AG GRONINGEN
The Netherlands

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://maillist.sys.kth.se/pipermail/gromacs.org_gmx-users/attachments/20021002/275f51d1/attachment.html>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: F.Hao.vcf
Type: text/x-vcard
Size: 207 bytes
Desc: Card for Fan Hao
URL: <http://maillist.sys.kth.se/pipermail/gromacs.org_gmx-users/attachments/20021002/275f51d1/attachment.vcf>

More information about the gromacs.org_gmx-users mailing list