[gmx-users] MPI + PME problems

Marc Baaden baaden at smplinux.de
Wed Jul 16 16:00:01 CEST 2003


I have some problems with PME jobs running on multiple processors
since lately. It happens with my system, but I can also reproduce
it with eg the speptide tutorial simulation.
If I run this simulation on eg 2 processors with Cutoff it is fine.
If I change to PME, I get

MPI process rank 0 (n0, p2866) caught a SIGSEGV in MPI_Type_extent.
Rank (0, MPI_COMM_WORLD): Call stack within LAM:
Rank (0, MPI_COMM_WORLD):  - MPI_Type_extent()
Rank (0, MPI_COMM_WORLD):  - MPI_Alltoall()
Rank (0, MPI_COMM_WORLD):  - main()

with no obvious error in the log files.
If I use the mpi executable with mpirun but on 1 processor, it is fine.

This did work in the past, and I have not changed the Gromacs code
that I use (3.1.4), so I suspect it is some library (version?) problem or some
missing option during Gromacs compilation.

Any hints ?

  Marc Baaden

NB: I run on a debian woody box with lam3_6.5.6-6 and mpich_1.2.1-16.
FFTW is sfftw2_2.1.3-12

 Dr. Marc Baaden  - Institut de Biologie Physico-Chimique, Paris
 mailto:baaden at smplinux.de      -      http://www.marc-baaden.de
 FAX: +49 697912 39550  -  Tel: +33 15841 5176 ou +33 609 843217

More information about the gromacs.org_gmx-users mailing list