[gmx-users] Bug? in version 3.1.4

istvan at kolossvary.hu istvan at kolossvary.hu
Tue Sep 23 16:45:02 CEST 2003


I was trying to "pdb2gmx" a simple peptide capped with ACE at the N-terminus 
and NAC at the C-terminus, but generating the hydrogens failed on NAC with 
an error message coming from genhydro.c "Atom CA not found in residue NAC3 
for while adding hydrogens". It turns out that the problem is a mismatch 
between respective .rtp and .hdb files. I specifically worked with oplsaa, 
but it seems that similar mismatches are present in the other force field 
files, too. For example, for oplsaa, the NAC carbon is a CH3 in the .rtp 
file, which is correct, but the same carbon in the corresponding .hdb file 
is a CA, which seems incorrect, because NAC does not have a CA. Changing the 
CA to CH3 in the .hdb file solved the problem. Since I am new to Gromacs, I 
am not sure that this is a correct fix, or I am missing something. 

Thanks for your help. 

  Istvan Kolossvary 

More information about the gromacs.org_gmx-users mailing list