[gmx-users] cpu detection in 3.2.1 double precision

Milton Taidi Sonoda msonoda at iqm.unicamp.br
Fri Aug 27 21:55:36 CEST 2004

Hi David
Yes, it should be. I have gromacs 3.2.1 in double precision installed
on Athlon MP with Linux RH 9.0 and FreeBSD 5.2.
Although Athon does not support it, gromacs tries to
probe SSE2.

Now, on Opteron 242 I have Fedora 2, for 64 bits,
gromacs doesn't try to probe SSE2. At least
there is nothing in the log file that shows this.

I've installed fftw-2.1.5 and gromacs 3.2.1 from
source code. I've also tried single precision and
enabling/disabling mpi, but none tried to find SSE/SSE2.

Could the 64 bits system has something to do with this?
Maybe it has a different directory tree.

Milton Taidi Sonoda

David wrote:

>On Thu, 2004-08-26 at 22:46, Milton Taidi Sonoda wrote:
>>I'm testing gromacs 3.2.1 in a two nodes cluster
>>of opteron 242, compiled in double precision.
>>I've searched the log and job files
>>for the stage where gromacs tries
>>to detect CPU version for optimization
>>but I didn't find it.
>It's in the md.log file. Look foor SSE:
>Testing x86 processor CPUID...
>CPU manufactured by AMD.
>Testing x86 SSE2 capabilities...
>CPU and OS support SSE2.
>Using Gromacs SSE2 double precision assembly innerloops.
>>I'm sure I didn't --disable-cpu-optimization
>>during configuration.
>>Is any thing wrong?
>>Is gromacs using the SSE2 or other capabilities
>>of opteron 242?
>>Thank you.
>>[ ]'s
>>Milton Taidi Sonoda
>>gmx-users mailing list
>>gmx-users at gromacs.org
>>Please don't post (un)subscribe requests to the list. Use the 
>>www interface or send it to gmx-users-request at gromacs.org.

More information about the gromacs.org_gmx-users mailing list