[gmx-users] Operation of tutorial

Itamar Kass ikass at cc.huji.ac.il
Sat Dec 4 09:10:28 CET 2004

Good morning Joe, this is due to the fact the osX does not recognize 
the links.  In order to over come it you should use the command's full 
path (e.g. /usr/local/gromacs/.../bin/pdb2gmx).

On Dec 3, 2004, at 11:59 PM, Oliver Beckstein wrote:

> Hi Joe,
> I am not using MacOS myself but perhaps it's more a simple
> shell/environment problem.
>> I am now working through the tutorials and have hit a second snag, in 
>> that
>> my computer is not recognizing the commands ³demo² or ³pdb2gmx². I 
>> have
>> successfully configured and installed both fftw and gromacs.  Upon
>> installation, the program placed the /bin file (which contains 
>> pdb2gmx)
>> inside of another directory, powerpc-apple-darwin7.6.0. I tried 
>> setting the
>> path in two ways using the setenv command described in the online
>> documentation, first as (in my case) /Users/jbozell/gromacs/bin, and 
>> then as
>> /Users/jbozell/gromacs/ powerpc-apple-darwin7.6.0/bin.  In both 
>> cases, when
> If you installed gromacs with the canonical 'make install' then you 
> should
> also have a file .../gromacs/powerpc-apple-darwin7.6.0/bin/GMXRC
> Then you should be able to setup the Gromacs environment by sourcing 
> it,
> ie
>   source .../gromacs/powerpc-apple-darwin7.6.0/bin/GMXRC
> (where ... = ~ or /Users/jbozell or whereever you installed it). This
> should also set paths to libraries, eg check with 'echo $GMXDATA'. In
> particular, it adds the bin directory to your PATH. You should now be 
> able
> to execute all gmx programs; check with
>   pdb2gmx -h
> For problems with demo I'm just guessing that perhaps the current
> directory '.' is not in your PATH and then you'd need to execute 
> './demo'
> instead of 'demo'.
>> I moved to the directory containing the first demo, entering ³demo² 
>> resulted
>> in the reply ³command not found².  I have also copied the bin file 
>> from its
>> initial location into the gromacs file and reset the path as
>> /Users/jbozell/gromacs/bin.  Again, the command is not recognized. I 
>> get the
>> same result from entering pdb2gmx.
> (I my comments above I assumed that the directoryt layout is the one
> after the initial installation.) Btw, you can have a look at GMXRC and
> GMXRC.csh (and the others) to find out where the Gromacs installation
> procedure beliefs your files to be located.
> Oli
> -- 
> Oliver Beckstein * oliver at biop.ox.ac.uk
>  http://sansom.biop.ox.ac.uk/oliver/
> _______________________________________________
> gmx-users mailing list
> gmx-users at gromacs.org
> http://www.gromacs.org/mailman/listinfo/gmx-users
> Please don't post (un)subscribe requests to the list. Use the
> www interface or send it to gmx-users-request at gromacs.org.

More information about the gromacs.org_gmx-users mailing list