[gmx-users] Power4 : Trying to install...

Pim Schravendijk schraven at mpip-mainz.mpg.de
Wed Jun 9 14:24:57 CEST 2004

Dear all,

I am trying to install gromacs 3.2.1 on a p690 power4 regatta system,
doing a single cpu, standard install (or at least trying to keep it simple
;) ), 

The system uses cc for compiling:
>  C for AIX Compiler, Version 6
Type system type according to gromacs is: 
> powerpc-ibm-aix5.2.0.0

Here is my step-by-step account:

Firstly, I installed fftw in single mode in my directory, that went ok,
Side note: it can find the fortran libraries, but then says:
> checking for dummy main to link with Fortran 77 libraries... unknown
and therefore fortran is not enabled. Is there a workaround for this?

I set LDFLAGS to the sfftw library and the MASS package, and set the 
CPPFLAGS to the sfftw library. Both are found during compilation.

# Problem #1:

./configure worked fine, I ended up with an error which has been on this 
list before:

>  "/usr/include/macros.h", line 30.10: 1506-236 (W) Macro name abs has 
> been redefined.
>  "/usr/include/macros.h", line 30.10: 1506-358 (I) "abs" is defined on 
> line 372 of /usr/include/stdlib.h.

The answer:
Didn't really work for me, I used 

$ setenv CFLAGS "-I../../include" 

But this didn't solve the problem, this flag appeared to be added after
the -I/usr/include flag (if it was added at all). 

* 'solution:'

Therefore I edited the src/gmxlib/Makefile and set INCLUDE =
-L../../include -L/usr/include I wonder why this won't go automatically
when setting that CFLAGS option.

Small note: during compilation of the inner loop, I get:
> "innerf.f", 1500-036 (I) The NOSTRICT option (default at OPT(3)) has the 
> potential to alter the semantics of a program.  Please refer to 
> documentation on the STRICT/NOSTRICT option for more information.
Any clues if this can really be a problem? 

# Problem #2:

My make now crashes at:
> "/usr/include/Xm/Xm.h", line 42.10: 1506-296 (S) #include file 
> <X11/extensions/Print.h> not found.
> "/usr/include/Xm/Xm.h", line 750.5: 1506-046 (S) Syntax error.
This seems strange to me, since both x and motif are present. 

* 'solution:'

Since this is a cluster install anyway, I just configured again with the
--without-x option.

# Problem #3:
Make goes along very well now, until somewhere during the "tools" part, 
where I get:

"/usr/include/stdio.h", line 487.12: 1506-343 (S) Redeclaration of 
fgetpos64 differs from previous declaration on line 296 of 
"/usr/include/stdio.h", line 487.12: 1506-377 (I) The type "long long*" of 
parameter 2 differs from the previous type "long*".

* 'solution:'
According to:
I should use:


Now the thing installs without problems, I can run the poly-ch2 simulation 
without problems. 

# Problem 4

Tried running d.villin benchmark:

in md.log:
> Started mdrun on node 0 Wed Jun  9 01:37:41 2004
> Initial temperature: 308.341 K
> Grid: 12 x 11 x 10 cells
> Using buffers of length 1000 for innerloop vectorization.
> t = 0.000 ps: Water molecule starting at atom 9387 can not be settled.
and it outputs some 9 crashed steps more...

Tried running d.lzm with the reaction field mdp file:

verbose output:
> starting mdrun 'LYSOZYME (E.C. in water'
> 5000 steps,     20.0 ps.
> Fatal error: realloc for _buf2 (6608 bytes, file fnbf.c, line 259, 
> _buf2=0x0x20bd4118): No such file or directory

Tried dppc:

verbose output:
> starting mdrun 'DPPC in Water'
> 5000 steps,     10.0 ps.
> Fatal error: realloc for _buf2 (4720 bytes, file fnbf.c, line 259, 
> _buf2=0x0x22ed90f8): No such file or directory

This is where Marc Baaden got stuck I guess, 

I tried some flags of Marc Ceruso 
( http://www.gromacs.org/pipermail/gmx-users/2004-June/010740.html ) 
but that didn't help me much on this.:

CFLAGS=-O3 -qarch=pwr4 -qtune=pwr4 -qansialias -w 
FFLAGS=-O3 -qarch=pwr4 -qtune=pwr4 -qansialias -w

Went to -O2 and -qstrict according to Campbell Millar's remark:

Now, different things went wrong e.g. for d.villin:
md.log output:
>Started mdrun on node 0 Wed Jun  9 14:19:11 2004
>Initial temperature: 308.342 K
>Grid: 12 x 11 x 10 cells
>Using buffers of length 1000 for innerloop vectorization.
>Fatal error: ci = -2147483648 should be in 0 .. 1319 [FILE nsgrid.c, LINE 218]

I believe Marc Baaden didn't win much by changing the _buf1 etc variable 
names? I've compiled with the -g option, any idea where I should look for?

The fact that the polymer benchmark works fine gives me the impression 
that somethings going wrong here with the water loops or something like 

It would be really nice if gromacs can be installed on these power4 
machines, there seem to be heaps of them in supercomputer centres :)

Greetings, Pim

Pim Schravendijk - PhD Student
Max Planck Institute for Polymer Research

More information about the gromacs.org_gmx-users mailing list