[gmx-users] mdrun using mpirun

jianzou zouj01 at mails.tsinghua.edu.cn
Wed Nov 3 08:45:45 CET 2004

> Hi Jianzou,
> it was a bit unclear for me, but did you use
> grompp -np 2 ...
> mpirun -np 2 mdrun_mpi -np 2 ...
> works for me at least.
> Best regards,
> Heikki

Thanks a lot, but I tried this but failed again:(

I've checked some posts here, and wonder that why someone use "mpirun -np 2 
mdrun_mpi ...", but you use "mpirun -np 2 mdrun_mpi -np 2". Which should be 

I wrote bhost for lam as
and run as lamboot -v bhost, grompp -np 2 -v, mpirun -np 2 mdrun_mpi -v
but got singal 11 error.

I also tried to include the full path for mpirun and mdrun, but it does not 
work in my case.

I check GROMACS User Manual v3.2 - Appendix A. Technical Details - Appendix 
A.5 Running GROMACS in parallel, which gives 2 examples

1. A typical command line looks like
    % mpirun -p goofus,doofus,fred 10 mdrun -s topol -v -N 30
   this runs on each of the machines goofus,doofus,fred with 10 processes on 

2. If you have a single machine with multiple processors you don't have to 
use the mpirun command, but you can do with an extra option to mdrun:
    % mdrun -np 8 -s topol -v -N 8
   In this example MPI reads the first option from the command line. Since 
mdrun also wants to know the number of processes you have to type it twice.

I tried "mdrun -np 2 -s topol.tpr -v -N 2" like the second example above, 
got the segmentation error.

Could anyone please help me out of this?

Thanks in advance.


Jian Zou

More information about the gromacs.org_gmx-users mailing list