[gmx-users] how to modify opls force field

Dongsheng Zhang dong at pampas.chem.purdue.edu
Mon Apr 18 01:28:18 CEST 2005

Dear Gromacs users,

I tried to use opsl force field to simulation a pentapeptide solution.
The residue in my pentapeptide is very similar to Methionine. The only
difference is the atom between CG and CE is O, not S (in Methionine).
Because this residue is not included in ffoplsaa.rtp, I made a new .rtp
file by adding a new residue. I named it MSO. The atom type for O in MSO
is opsl_999 (I treated it as opsl_180, O in the dialkyl ether). I also
modified ffoplsaa.atp, ffoplsaabon.itp, ffoplsaa.hdb, ffoplsaa.itp and
ffoplsaanb.itp by adding new parameters. In short, I made my own force
field for my pentapeptide, and I gave it a new name. However, when I
tried to use pdb2gmx to convert my pdb file, I got the error message as

No N- or C-terminus found: this chain appears to contain no protein
Fatal error: Atom -C not found in residue MSO1 while adding hydrogens

Because I just added more parameters to opsl force field to get my own
force field, I think my new force field should work for Methionine
pentapeptide, so I changeed my pdb file to Methionine pentapeptide. When
I tried pdb2gmx, it worked fine.

Another test I have done is I modified ffoplsaa.rtp by changing the
definition of MET, namely I changed SD to OD in [MET] section (and
changed other things accordingly). I also changed SD to OD in MET
section in the file ffoplsaa.hdb. Then I tried pdb2gmx, it worked as

Could anyone tell me what's wrong with the modification by adding one
more residue type? Any helps are highly appreciated. If you need more
information, please let me know.

Thanks in advance!

Dongsheng Zhang <dong at pampas.chem.purdue.edu>

More information about the gromacs.org_gmx-users mailing list