[gmx-users] g_dielectric error

paolo marracino paolomarracino at hotmail.com
Tue Apr 11 11:15:01 CEST 2006

Hi, I've some problems in using the command g_dielectric in various example 
of water(spc ,tip5, tip4).The error appears to be the same for each 
model;this is for spc water model:

Read data set containing 2 colums and 101 rows
Assuming (from data) that timestep is 0.1, nxtail = 101
Creating standard deviation numbers ...
nbegin = 50, x[nbegin] = 5, tbegin = 5
Step       chi^2      Lambda          A1          A2          A3
   0  7.53836e+03  1.00000e-02  0.00000e+00
   1  7.53836e+03  1.00000e-01  0.00000e+00
   2  7.53836e+03  1.00000e+00  0.00000e+00
   3  7.53836e+03  1.00000e+01  0.00000e+00
   4  7.53836e+03  1.00000e+02  0.00000e+00
   5  7.53836e+03  1.00000e+03  0.00000e+00
   6  7.53836e+03  1.00000e+04  0.00000e+00
   7  7.53836e+03  1.00000e+05  0.00000e+00
   8  7.53836e+03  1.00000e+06  0.00000e+00
   9  7.53836e+03  1.00000e+07  0.00000e+00
  10  7.53836e+03  1.00000e+08  0.00000e+00
  11  7.53836e+03  1.00000e+09  0.00000e+00
  12  7.53836e+03  1.00000e+10  0.00000e+00
  13  7.53836e+03  1.00000e+11  0.00000e+00
  14  7.53836e+03  1.00000e+12  0.00000e+00
  15  7.53836e+03  1.00000e+13  0.00000e+00
  16  7.53836e+03  1.00000e+14  0.00000e+00
  17  7.53836e+03  1.00000e+15  0.00000e+00
  18  7.53836e+03  1.00000e+16  0.00000e+00
  19  7.53836e+03  1.00000e+17  0.00000e+00
  20  7.53836e+03  1.00000e+18  0.00000e+00
  21  7.53836e+03  1.00000e+19  0.00000e+00
  22  7.53836e+03  1.00000e+20  0.00000e+00
  23  7.53836e+03  1.00000e+21  0.00000e+00
  24  7.53836e+03  1.00000e+22  0.00000e+00
  25  7.53836e+03  1.00000e+23  0.00000e+00
  26  7.53836e+03  1.00000e+24  0.00000e+00
  27  7.53836e+03  1.00000e+25  0.00000e+00
  28  7.53836e+03  1.00000e+26  0.00000e+00
  29  7.53836e+03  1.00000e+27  0.00000e+00
  30  7.53836e+03  1.00000e+28  0.00000e+00
  31  7.53836e+03  1.00000e+29  0.00000e+00
  32  7.53836e+03  1.00000e+30  0.00000e+00
  33  7.53836e+03  1.00000e+31  0.00000e+00
  34  7.53836e+03  1.00000e+32  0.00000e+00
  35  7.53836e+03  1.00000e+33  0.00000e+00
  36  7.53836e+03  1.00000e+34  0.00000e+00
  37  7.53836e+03  1.00000e+35  0.00000e+00
  38  7.53836e+03  1.00000e+36  0.00000e+00
  39  7.53836e+03  1.00000e+37  0.00000e+00
  40  7.53836e+03  1.00000e+38  0.00000e+00
  41  7.53836e+03         inf  0.00000e+00
  42  7.53836e+03         inf  0.00000e+00
  43  7.53836e+03         inf  0.00000e+00
  44  7.53836e+03         inf  0.00000e+00
  45  7.53836e+03         inf  0.00000e+00
  46  7.53836e+03         inf  0.00000e+00
  47  7.53836e+03         inf  0.00000e+00
  48  7.53836e+03         inf  0.00000e+00
  49  7.53836e+03         inf  0.00000e+00

Program g_dielectric, VERSION 3.3
Source code file: expfit.c, line: 465

Fatal error:
nparm = 0 in file expfit.c, line 466

I tried to find out what kind of error gromacs is reproducing but in the 
file expfit.c  (in the directory /src/tools ) I couldn't find anything 
useful and so for the file gmx_dielectric.c
Is the nparm error due to bad parmters initialization?
I tried different values for 'A' 'tau1' 'tau2' in g_dielectric but the 
result is the same.
I tried different force fileds in the top file but again nothing.
Any useful tip?

More information about the gromacs.org_gmx-users mailing list