[gmx-users] mdrun with mpich

Pradeep Kota kotanmd at gmail.com
Thu Feb 2 03:43:23 CET 2006

Dear users,
    I have compiled gromacs on our dual core mac os x G5 cluster, and tried
running a simulation on a 540 residue protein for 1 ns on 8 processors. i
used mpich as the mpi environment for parallelising gromacs. it worked fine,
and the job was split properly and assigned to nodes. now, the cpu usage per
processor is not more than 50% on any of the processors. and the total
running time for this was 13hrs. though output is written properly onto the
specified output file, mdirun doesnot terminate even after running through
all the steps. it still shows two mdrun_mpi processes running on the head
node, with a 0% cpu usage. was going through gmx-users mailing list and
somehow figured out that mpich is not a good idea for running gromacs. so, i
wanted to switch over to lam. now when i complie gromacs using lam, it is
not able to link the libraries properly. so, i tried reinstalling lam on my
cluster. now, lam keeps complaining about not being able to find a fortran
compiler. i should not need a fortran compiler unless i'm using SUN or SGI
for this purpose..(am i going wrong here?). what flags do i need to compile
lam with, in order to compile gromacs successfully? any help is very much
thanks in advance,
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://maillist.sys.kth.se/pipermail/gromacs.org_gmx-users/attachments/20060202/c5cc24ad/attachment.html>

More information about the gromacs.org_gmx-users mailing list