[gmx-users] cross compiling gromacs

ganapathy senthilkumar rgskumar1983 at gmail.com
Wed May 3 13:01:01 CEST 2006

dear gromacs users,
I tried to cross-compile gromacs for powerpc on an intel x86
machine. i set the configure options as

export CPPFLAGS=-I/mnt/usr/local/include
export LDFLAGS=-L/mnt/usr/local/lib

=>i had mounted another root file system(simulated) onto mnt.
i ran the configure script with the following options.

./configure  --prefix=/mnt/usr/local/ 
-m32 -Wl,-m,elf32ppc"  --enable-portable-binary
CFLAGS=-L/home/murali/cell1.0.1/sysroot/usr/lib  --host=powerpc64-linux

on doing make i got the following error

./mknb   -software_invsqrt
./mknb: ./mknb: cannot execute binary file
make[5]: *** [kernel-stamp] Error 126
make[5]: Leaving directory `/home/murali/gromacs/gromacs-3.3.1
make[4]: *** [all-recursive] Error 1
make[4]: Leaving directory `/home/murali/gromacs/gromacs-3.3.1
make[3]: *** [all-recursive] Error 1
make[3]: Leaving directory `/home/murali/gromacs/gromacs-3.3.1/src/gmxlib'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/home/murali/gromacs/gromacs-3.3.1/src'
make[1]: *** [all] Error 2
make[1]: Leaving directory `/home/murali/gromacs/gromacs-3.3.1/src'
make: *** [all-recursive] Error 1

i understand that the mknb file generated by make is an powerpc executable
and therefore cannot be executed.(since i am on a intel machine).

kindly help me solve this problem.thank you in advance.

ganapathy senthilkumar
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://maillist.sys.kth.se/pipermail/gromacs.org_gmx-users/attachments/20060503/ee3b2b99/attachment.html>

More information about the gromacs.org_gmx-users mailing list