[gmx-users] grompp problems

Ken Rotondi ksr at chemistry.umass.edu
Tue Oct 3 23:31:35 CEST 2006

Hi all,

I'm having troubles with grompp.

Building .gro and .top files from a .pdb file of a 7 residue peptide 
(61 atoms in uaff) results in a system with  5137 atoms in the gro file 
and a .top file with 1 protein (61 atoms) and 1692 solvent (5076 
atoms). When I ran grompp it fatal erred stating that the "number of 
coordinates in the coordinate file (5137 atoms) does not match topology 
(0 atoms).

My .mdp file had the default

cpp  =  /lib/cpp

so I ran the command; 'which cpp', which returned /usr/bin/cpp

I changed the .mdp to

cpp  =  /usr/bin/cpp

and I get the same error.

If I run grompp with the -pp option the processed top file returned is 

Could this have something to do with the

include  =  -I../top

in the preprocessing section of the .mdp file? It would seem to be the 
only thing left.

This is a linux box running Fedora Core 5. No significant modifications 
were made during the install of either the OS or GROMACS.



More information about the gromacs.org_gmx-users mailing list