[gmx-users] qm_mopac.c problems in building of 3.3.1

Jake Michaelson jake.michaelson at gmail.com
Fri Oct 6 20:41:42 CEST 2006

Hi all,

I'm trying to build a qmmm-enabled version of gromacs 3.31 with MOPAC7.
My specs:

Intel Core 2 Duo
Ubuntu 6.06 with kernel 2.6.18-ck1 (x86-64)
compiling with Intel MKL 8.1.1, icc v 9.1, ifort v 9.1
MOPAC7 v 1.10

MOPAC compiles nicely with the above, but when I try to build gromacs

export LIBS="-lmkl -lguide -lpthread -lmkl_lapack -lmopac7 -lg2c"

./configure --prefix=/usr --with-fft=mkl --with-external-blas
--with-external-lapack --with-qmmm-mopac --with-x

Make eventually dies with (snippet):

../mdlib/.libs/libmd.a(qm_mopac.o): In function `/bin/sh ../../libtool
--tag=CC --mode=link /opt/intel/cce/9.1.043/bin/icc  -openmp -xT
-L/usr/atlas/lib -L/opt/intel/cce/9.1.043/lib
-L/opt/intel/fce/9.1.037/lib -L/usr/lib64  -o protonate hackblock.o
ter_db.o h_db.o genhydro.o pgutil.o resall.o add_par.o topexcl.o
toputil.o topdirs.o protonate.o ../mdlib/libmd.la ../gmxlib/libgmx.la
-L/usr/X11R6/lib -lnsl -lmkl -lmkl -lguide -lpthread -lmkl_lapack
-lmopac7 -lg2c  -lSM -lICE -lX11
call_mopac':qm_mopac.c:(.text+0x135): undefined reference to `domop_'
../mdlib/.libs/libmd.a(qm_mopac.o): In function
`call_mopac_SH':qm_mopac.c:(.text+0x38f): undefined reference to
../mdlib/.libs/libmd.a(qm_mopac.o): In function
`init_mopac':qm_mopac.c:(.text+0x541): undefined reference to `domldt_'
make[3]: *** [mdrun] Error 1

...basically undefined references to domop_ and domldt_ in qm_mopac.c.
I'm not sure where these are supposed to be found.  Can anyone give me a
hand on this?

For what it's worth I've also tried building both MOPAC7 and gromacs  
with gcc, but I got exactly the same error, which suggests that this  
is not a compiler-specific problem.



More information about the gromacs.org_gmx-users mailing list