[gmx-users] short range nonbondeds = 0 in power4

Atte Sillanpää asillanp at csc.fi
Thu Sep 14 16:11:00 CEST 2006


I've run into a mysterious problem. The versions 3.3. and 3.3.1 compile and 
execute, but the short range coulomb and LJ energies come out as zero when 
using the mpi-version. Serial code works ok (mpi version gives zero if run 
using just one cpu). No errors, no warnings.

I've tried using both fftw 2.1.5 and 3.0.1, tried dropping the optimization 
level to -O1, -qstrict, --disable-ppc-altivec, ...

The config options were (e.g.) as follows:

setenv CPPFLAGS -I/v/aix52_rs/appl/math/fftw/fftw-3.0.1_32/include
setenv LDFLAGS -L/v/aix52_rs/appl/math/fftw/fftw-3.0.1_32/lib
setenv MPICC mpcc_r
./configure --prefix=/wrk/gmx --program-suffix="_mpi" --enable-mpi 
--disable-nice --enable-threads -with-fft=fftw3

>From the beginning of the config.log:

hostname = p690m
uname -m = 00105CDA4C00
uname -r = 2
uname -s = AIX
uname -v = 5

/usr/bin/uname -p = powerpc
/bin/uname -X     = unknown

/bin/arch              = unknown
/usr/bin/arch -k       = unknown
/usr/convex/getsysinfo = unknown
hostinfo               = unknown
/bin/machine           = unknown
/usr/bin/oslevel       =
/bin/universe          = unknown

We don't get the kind of errors described earlier for power4 on the list. I 
actually managed to make a working mdrun_mpi from 3.3 last year using the same 
options, but after poe/ppe/... update on the power4 machine I get this odd 
behaviour also on the 3.3 version. Any ideas? What to tweak, where to look?



More information about the gromacs.org_gmx-users mailing list