[gmx-users] short range nonbondeds = 0 in power4

Atte Sillanpää asillanp at csc.fi
Mon Sep 18 12:53:25 CEST 2006

On Fri, 15 Sep 2006, Atte Sillanpää wrote:

>>>>> I've run into a mysterious problem. The versions 3.3. and 3.3.1 compile
>>>>> and execute, but the short range coulomb and LJ energies come out as
>>>>> zero when using the mpi-version. Serial code works ok (mpi version gives
>>>>> zero if run using just one cpu). No errors, no warnings.


the problem seems solved. I removed the --enable-threads from the
gromacs config options and now short range forces come out right.
Simulations are stable and e.g. water rdfs are identical in power4 and
amd opteron. It's a little bit nasty that compiler gets through the
threads flag but then computes garbage.

It has been said in the mailing list that threads don't work yet, but
that's hard to find as the solution unless you know to look for it.

To further check my binary I'd like to do some other tests. I tried
looking for the benchmarks, but the link doesn't work (search for
'bench' at the gromacs site). Are they still available (and do they
have some verified results to compare to?)



More information about the gromacs.org_gmx-users mailing list