[gmx-users] Re: Gromacs and mpirun

Lam Nguyen Sy thelord_voldemort at yahoo.com
Sat Jul 7 18:57:46 CEST 2007

Dear Gromacs users,

I'm trying to run Gromacs version 3.3.1 in parallel.
The following are what I did and what I encountered:

${direxe1}/mpirun  -np ${ncpu} ${direxe}/mdrun_d_mpi 
-np ${ncpu} -s ${type2}.tpr  -e ${type2}.edr -o
${type2}.trr -g ${type2}.log -c ${type2}.gro

Fatal error:
run input file md961.tpr was made for 2 nodes,
while mdrun_d_mpi expected it to be for 1 nodes.

Certainly, I did grompp_d_mpi before mdrun_d_mpi.

And the below is the whole story.

I used to run Gromacs in parallel without any
difficulty on a Beowulf cluster. I did like this:

mpd &
mpirun ... mdrun_d_mpi

But, everything has changed since the administrator of
the cluster upgraded the system from python2.3 to
python2.4. I cannot use "mpd" anymore,

mpd &
/usr/bin/env: python2.3: No such file or directory

Instead, I did the following way and Gromacs could run
in parallel:

python2.4 {path_to_Mpich}/bin/mpd &
python2.4 mpirun ...mdrun_d_mpi

I had to put "python2.4" before any command related to
mpi (I don't know why). But, a very strange thing
happened. With the preceeding python2.4, Gromacs could
run in parallel within 70 minutes with 100% and 92% of
each processor (before, they were just 99% each), then
it broke with these lines:

mpiexec_bw4: cannot connect to local mpd
(/tmp/mpd2.console_nslam); possible causes:
1. no mpd is running on this host
2. an mpd is running but was started without a
"console" (-n option)

and there was no mpd anymore.

Then, I tried to reinstall fftw-3.1.2 and
gromacs-3.3.1 in the following way (I thought that
gromacs did recognize something new on the system):


./configure --enable-double


export CPPFLAGS=-I/MPI/nslam/fftw-3.1.2/include/
export LDFLAGS=-L/MPI/nslam/fftw-3.1.2/lib/
./configure --enable-double --enable-mpi
--program-suffix='_d_mpi' --prefix=/MPI/nslam/GR/

These are what I did long time ago, and Gromacs had
been working very properly till the time of upgrading.

The suceeding "make" and "make install" of those
packages gave no complain (certainly, I did "make
distclean" before recompiling). But, the situation was
exactly the same as what before I reinstalled them.
With the preceeding "python2.4", Gromacs could run
with 100% and 92% cpu within just about 70 minutes,
then broke with no mpd. 
I thought the problem wasn't of gromacs-3.3.1, but the
mpi on the system. Unfortunately, the administrator of
the system didn't want to think that it was the
problem of the mpi he did install. Therefore, I tried
to install mpi myself. I did:

./configure --with-arch=LINUX --with-device=ch_p4
-rsh=/usr/bin/ssh --prefix=/MPI/nslam/mpich-1.2.7p1
After that, I did "make distclean" in both fftw and
gromacs and recompiled them the same way as above,

export MPI=/MPI/nslam/mpich-1.2.7p1/bin
export MPICHHOME=/MPI/nslam/mpich-1.2.7p1/bin

Then what I did and received are what was said at the
beginning of this message. Besides, it was ok when I
did that way with ncpu=1.

Now I don't know what is the problem, of mpi or of
Gromacs for parallel running? 

I'm not sure that my story and my questions are posed
on the appropriate mailing list. Forgive me if it was
not the case.

Is there any idea on my problem? If there is, it will
be very useful for me.

Thank you very much,

And have a nice weekend


Take the Internet to Go: Yahoo!Go puts the Internet in your pocket: mail, news, photos & more. 

More information about the gromacs.org_gmx-users mailing list