[gmx-users] grompp error with cpp

toma0052 toma0052 at umn.edu
Sat Mar 24 01:02:33 CET 2007

     I just installed Gromacs on my windows machine under cygwin, and
everything seemed to go fine with the installation and whatnot.  Initially,
when I tried to run a simulation, I obtained the error that Gromacs found the
number of coordinates in my .top file to be 0, because it could not find the
cpp.  From the mailing list archives, I gathered that Gromacs was checking
for cpp in /lib/cpp whereas in cygwin the cpp is in /bin/cpp.  So, as in the
post, I created a link in /lib pointing to /bin/cpp.  I ran a simulation, and
everything went fine.  Now, I am trying to run another simulation, and I am
running into the same problem as before.  When I execute grompp, I get this
Back Off! I just backed up md_shear_run.mdp to ./#md_shear_run.mdp.2#
checking input for internal consistency...
...ling /lib/cpp
: No such file or directory
cpp exit code: 32512
 dppc.top > gromppt9guCt're/gromacs/top -DPOSRES
' command is defined in the .mdp file
processing topology...
processing coordinates...
Program grompp, VERSION 3.3.1
Source code file: grompp.c, line: 448

Fatal error:
number of coordinates in coordinate file (md_start_1000.gro, 17365)
             does not match topology (dppc.top, 0)

>From this, I gather that Gromacs cannot find the cpp, however, if I look in
/lib, the file cpp.exe exists there.  I don't think that I have changed
anything with the paths since my last successful run, so why now can Gromacs
not locate the cpp?  Is there something that I am missing?

Mike Tomasini

More information about the gromacs.org_gmx-users mailing list