[gmx-users] Problems with fftw libraries during gromacs configure

Mark Abraham Mark.Abraham at anu.edu.au
Tue Mar 27 03:28:11 CEST 2007

Mario Campo wrote:
> Hellow !
> I'm stalling gromacs in a intel--intel PC (mather d646gzis -core duo 
> porcessor) with a fedora system.
> can somebody suggest me some gromacs version?

Always, the most recent one! i.e. 3.3.1

> Anyway, I tried to install gromacs-3.3.1 with the tar.gz archive. 
> Previously I installed fftw with the fftw-3.1.2.tar.gz.
> When I run configure of gromacs, the next message appears:
> 'the ffw3f library can not found' (or something like that)
> THE PROBLEMS IS: Error message doesn't indicate me which file it doesn't 
> find, then I can not "tell him" where "to find it"
> I already without success drained the readings of the "readme" files and 
> similar things, trying to change the path etc.

gromacs requires a single-precision FFTW library (the 'f' suffix) and 
the default build for FFTW builds only a double-precision library with 
no suffix. This is why following the installation instructions here 
http://www.gromacs.org/gromacs/documentation/prerequisites.html would 
have been a good idea :-)


More information about the gromacs.org_gmx-users mailing list