[gmx-users] make gives error in futil.c with mpi and ccc-

Chris Neale chris.neale at utoronto.ca
Wed Nov 14 23:59:07 CET 2007

I am having difficulty installing the mpi version of gromacs 3.3.2 on  
a new computer. I have the same problems for 3.3.1. The serial version  
appears to have worked fine. The cluster uses elan for MPI 
I have parsed some values from config.log 

configure:3291: ccc -V >&5
Compaq C T6.5-002 on Linux 2.4.21-3.7qsnet alpha
Installed as ccc-
Red Hat Linux release 7.2 (Enigma)
Using /usr/lib/gcc-lib/alpha-redhat-linux/2.96 (4).
Compiler Driver T6.5-001 (Linux) cc Driver

I believe my previous post was rejected since it was >2000 lines so I have put the
entire config.log here: http://www.pomeslab.com/CN_GromacsPost_111407.html
and reposted.
mpicc appears to link like this (although the script is complicated enough
that I am not sure if this variable gets modified later):
my %mpilibs ='-L/usr/lib/mpi/mpi_compaq/lib -lmpifarg -lmpi -lelan'

I think that I must have autoconf somewhere since the Makefile was created, however:
$automake --version
automake (GNU automake) 1.4-p5
$ autoconf --version
bash: autoconf: command not found

I have found some posts related to futil.c including the following  
potential fix
but I didn't understand where the quotes were intended to go and the  
next reply indicates that this is not a good idea in any event.

Another post indicates that I may be required to link it myself and  
avoid the mpicc wrapper. I have tried including the following lines in  
my compilation script before calling configure

export CC=gcc
export MPICC=gcc
export LIBS="-lmpi"

but configure ends very quickly with the error message:
checking for C compiler default output file name... configure: error:  
C compiler cannot create executables

Thanks for any assistance.


I ran it like this:


cd $MD

mkdir exec
export FFTW_LOCATION=/home/cneale/exe/fftw-3.1.2/exec
export GROMACS_LOCATION=${MD}/exec
export CPPFLAGS="-I$FFTW_LOCATION/include"

./configure --prefix=$GROMACS_LOCATION --enable-mpi  
--program-suffix="_mpi" --disable-nice > output.mpi_configure 2>&1
make mdrun > output.mpi_make_mdrun 2>&1
make install-mdrun > output.mpi_make_install_mdrun 2>&1
#make distclean


The first error in the 'make mdrun' output is:

source='futil.c' object='futil.lo' libtool=yes \
DEPDIR=.deps depmode=none /bin/sh ../../config/depcomp \
/bin/sh ../../libtool --tag=CC   --mode=compile mpicc -DHAVE_CONFIG_H  
-I. -I../../src  -I../../include  
-I/home/cneale/exe/fftw-3.1.2/exec/include  -std1 -fast -O4 -no_ifo  
-arch ev6 -unroll 2 -fp_reorder -c -o futil.lo futil.c
  mpicc -DHAVE_CONFIG_H -I. -I../../src -I../../include  
-I/home/cneale/exe/fftw-3.1.2/exec/include -std1 -fast -O4 -no_ifo  
-arch ev6 -unroll 2 -fp_reorder -c futil.c -o futil.o
cc: Error: futil.c, line 521: Invalid expression. (badexpr)
cc: Warning: futil.c, line 521: Invalid token discarded. (invaltoken)
make[2]: *** [futil.lo] Error 1
make[2]: Leaving directory `/mnt/scratch/cneale/exe/gromacs-3.3.2/src/gmxlib'
make[1]: *** [all-recursive] Error 1

make[1]: Leaving directory `/mnt/scratch/cneale/exe/gromacs-3.3.2/src/gmxlib'

More information about the gromacs.org_gmx-users mailing list