[gmx-users] Re: SGI Altix - mdrun_mpi

Chris Neale chris.neale at utoronto.ca
Thu Nov 15 00:23:22 CET 2007

Included with the things you recently tried did you use 'mpirun N mdrun -np 2' in place of 
'mpirun -np 2 mdrun -np 2'? I'm certainly no expert, but it is a difference between our scripts.
Otherwise I don't know. Perhaps recompile gromacs. Probably you have looked at this but did you check
to see that yout .tpr file was created properly? Also you may want to try a 'sleep 10' between
grompp and mdrun in case you have NFS delay issues.

Good luck,

### original message 
Hi Chris, again ;-)

I'm also running gromacs on another Cluster intel based ( using PBS), 
and my script submission procedure is similar to yours!

Now, this new machine I'm trying to use is a SGI 64-way, thus I think 
that the lam nodes file is correct: 64 cpu's in a single node, or 
something like that. And, as you can see, the "hello" program does work 
on this machine when called from mpirun.

As I told in my previous e-mail, there are people using the LAM-MPI on 
this machine, and in fact, the hostfile and part of the script 
submission file were written by my colleagues. Thus, I think that the 
hostfile is correct, and that probably something is not ok with the 
submission file,  the gmx compilation (though the compilation was 
successful) or even with the system configuration.

I tried also the suggestions in your script (exporting PATH, 
LD_LIBRARY_PATH, LAMRSH), but getting exactly the same error.
Oh well ...

Thanks for the reply,

More information about the gromacs.org_gmx-users mailing list