[gmx-users] pdb2gmx error - version 3.3.1

Justin A. Lemkul jalemkul at vt.edu
Tue Oct 16 20:40:34 CEST 2007

Hello all,

I am having a strange error when using pdb2gmx.  I am trying to generate the
topology for a simple protein, using Gromos96 43a1.  I am able to create the
topology with version 3.3 without issue.  However, if I use pdb2gmx under
version 3.3.1, I encounter this:

$ pdb2gmx -f protein.pdb -o protein.gro -ignh

(pdb2gmx runs through its normal routine...)

Program pdb2gmx, VERSION 3.3.1
Source code file: pgutil.c, line: 87

Fatal error:
Atom N not found in residue 1 while adding improper


If I try the ffgmx force field, everything works fine.  There are no broken
residues in the PDB (it's one that I've worked with before, just with a
different force field).

I have not tried to generate the topology under version 3.3.2, because our
university's cluster only has versions 3.3 and 3.3.1 available.  I suppose I
can just use version 3.3, but I thought I should bring up this issue in case it
needs fixing in future versions (or in case I'm missing something that should be
an easy fix).



Justin A. Lemkul
Graduate Research Assistant
Department of Biochemistry
Virginia Tech
Blacksburg, VA
jalemkul at vt.edu | (540) 231-9080


More information about the gromacs.org_gmx-users mailing list