[gmx-users] GDB Debugging - GROMACS(v-3.3.3) Application with OpenMPI(v-1.2.5/v-1.2.6)

Mukesh K Srivastava srimks11 at gmail.com
Thu Apr 17 19:36:50 CEST 2008


Anyone had performed GDB debugging for Gromacs(v3.x - v3.3.3) application
with FFTW(v3.1) using OpenMPI(v-1.2.5 or v-1.2.6). I had properly configured
OpenMPI with debug option and also configured Gromacs alongwith FFTW
succesfully. I can perform p2bdbx_mpi, editconf_mpi, genbox_mpi, grompp_mpi
compilation and finally mdrun_mpi without any error or warning messages. But
while executing mdrun_mpi w.r.t mprun, I get libmpi.so.0 not found.

I had tried with LD_LIBRARY_PATH, forcefully mentioning PATH &
LD_LIBRARY_PATH in etc/bashrc file and also tried with providing softlink to
libmpi.so.0, but everytime I get same error message of "libmpi.so.0" not

I had check ldd and it's dependency of executable mdrun_mpi, checked it's
symbol table content, and finally all lib's configured for 64 bit with ELF
format but still getting same error of libmpi.so.0 not found while
performing GDB serial debugging with single node.

Note: I had performed GDB debugging for small MPI program(hello world) using
OpenMPI(v1.2.5/v1.2.6) wthout GROMACS association succesfully.

Any clue plz?

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://maillist.sys.kth.se/pipermail/gromacs.org_gmx-users/attachments/20080417/6b05965e/attachment.html>

More information about the gromacs.org_gmx-users mailing list