[gmx-users] rb1 test failed after recompiling gromacs 3.3.2

Nicolas Sapay nsapay at ucalgary.ca
Wed Aug 20 20:41:53 CEST 2008


I've run the gmxtest on Gromacs-3.3.2. One simple test failed:

    Testing rb1 . . . *** glibc detected *** realloc(): invalid next
    size: 0x082c0180 ***
    sh: line 1: 27398 Aborted                 mdrun >mdrun.out 2>&1
    FAILED. Check files in rb1

And two complex tests failed as well:

    Testing acetonitrilRF . . . FAILED. Check files in acetonitrilRF
    Testing dec+water . . . FAILED. Check files in dec+water

In the case of the rb1 test, I checked all the .out .log files but found 
anything wrong. For acetonitrilRF, I obtain this:

    Program mdrun, VERSION 3.3.2
    Source code file: network.c, line: 437

    Routine should not have been called:

According to the mailing list, there is something to fix in 
src/mdlib/rf_util.c. For dec+water, I've got the same error than on the 
wiki, so nothing to worry about apparently.Following the advices found 
on the wiki or the mailing list, I have re-compiled FFTW and Gromacs 
(with fixed rf_util.c) from the sources. For FFTW, I've used the 
following command:

    ./configure --prefix /usr/export/fftw-3.1.2/ --enable-float
    --enable-threads CC=/usr/bin/gcc

And for Gromacs:

    ./configure --prefix /usr/export/gromacs-3.3.2 --without-x
    CC=/usr/bin/gcc CPPFLAGS=-I/usr/export/fftw-3.1.2/include/

I have rerun the test but I still obtain the same error with the rb1 
test (and the dec+water test). Can someone explain to me what the it 
means exactly and how to fix it? (I guess it's related to the 
Ryckaert-Bellemans potential?).


ps: I'm using RHE 4.7 and gcc 3.4.6

-------------- next part --------------
A non-text attachment was scrubbed...
Name: nsapay.vcf
Type: text/x-vcard
Size: 282 bytes
Desc: not available
URL: <http://maillist.sys.kth.se/pipermail/gromacs.org_gmx-users/attachments/20080820/a7863a15/attachment.vcf>

More information about the gromacs.org_gmx-users mailing list