[gmx-users] Problem with trjcat -demux

Justin A. Lemkul jalemkul at vt.edu
Fri Dec 19 16:15:23 CET 2008

Hi all,

I've just begun some work with REMD using Gromacs-4.0.2; it is my first real 
attempt at doing REMD, so I'm trying to learn the correct procedure.  At the end 
of the simulations (9 replicates @ 1ns each, just a quick test of how everything 
works), I want to try to assemble continuous trajectories using trjcat -demux. 
The demux.pl script worked to give me the two necessary index files.  Following 
the information on the wiki, I tried the following:

trjcat -f ../*.xtc -demux ../replica_index.xvg

I got the following error:

Read 9 sets of 500 points, dt = 2

Reading frame     120 time   28.000
Program trjcat_4.0.2_s, VERSION 4.0.2
Source code file: gmxfio.c, line: 938

Range checking error:
Variable fio has value 13691. It should have been within [ 0 .. 10 ]


Have I done something wrong, or is there a problem in trjcat?

Thanks for your attention.



Justin A. Lemkul
Graduate Research Assistant
Department of Biochemistry
Virginia Tech
Blacksburg, VA
jalemkul[at]vt.edu | (540) 231-9080


More information about the gromacs.org_gmx-users mailing list