[gmx-users] popc

chris.neale at utoronto.ca chris.neale at utoronto.ca
Fri Mar 21 17:24:26 CET 2008

You are experiencing problems because popc is not a protein and  
pdb2gmx is currently only set up for proteins. More importantly, you  
already have popc.itp so you don't need to run  pdb2gmx on it.

I suggest that you read the manual more closely about setting up a  
simulation and clarify your ideas about the purpose of pdb2gmx, and  
what .top and .itp files are for.

I have posted previously on this topic, so the search that Justin  
recommended should be fruitful. Briefly, use pdb2gmx on your protein  
then separate out the protein specific part to protein.itp. Then  
include protein.itp and lipid.itp in your .top file and set the number  
of each in your [ molecules ] section.

There are some links here:  

I have been thinking to update that section with some more specific  
information, but I am not sure how useful that will be until the wiki  
is searchable by the main mailing list search engine since these two  
places to get info are currently disconnected.


*** original message ***

Dear gromacs users,

  I would like to perform  simulations of a protein embedded in popc, using a
force field of the gromos series and I downloaded popc.pdb, popc.itp,
lipid.itpa and the force field ffG43a2x extended for lipids.
Looking throughout the archive I found different suggestions, but none of
them help me to successfully perform my simulations:

- Using the ffG43a2x* force field, when I run pdb2gmx on the popc.pdb, I get
this error:

  Fatal error:

Error in hdb file ffG43a2x.hdb:

Wrong number of control atoms (2 iso 3) on line:

1 1 N -C CA

   - If I manually write a topology file for the ffG43a2x force field and
submit it to grompp to write a .tpr, I get this error:

  Fatal error:
Atomtype 'CA' not found!

   In the topology file I included both lipid.itp and popc.itp, and I
commented the following lines in the lipid.itp file as suggested:

  [ defaults ]

1 1

  - I also tried to add the different sections [ atomtypes ], [ pairtypes ],
etc... of the lipid.itp files to ffG53a5* files, but I still get the error:

  Atomtype 'CA' not found!

  Does anybody know what I miss? Is there a way to resolve this problem and
use popc with ffG53a5 or ffG43a2x?

  All comments are very appreciated!
Thanks in advance!


More information about the gromacs.org_gmx-users mailing list