[gmx-users] running a simulation without production

Mark Abraham Mark.Abraham at anu.edu.au
Fri Nov 7 00:41:21 CET 2008

Zuzana Benkova wrote:
> -----Original Message-----
> From: gmx-users-bounces at gromacs.org [mailto:gmx-users-bounces at gromacs.org]
> On Behalf Of Zuzana Benkova
> Sent: Tuesday, November 04, 2008 3:11 PM
> To: 'Discussion list for GROMACS users'
> Subject: RE: [gmx-users] running a simulation without production
> Dear Mark, 
> Thank you very much for valuable advice. 
> Previously, I run some simulations and I obtained what I had expected. For
> instance, instead of the plate I have just used one single chain which was
> treated as frozen and the simulations were running. I obtained all output
> files containing appropriate information. 
> I have GMX version 3.3.3. I have just tried gmxtest.pl test first in sthe
> ingle precision. The output I got was
> All 16 simple tests PASSED
> FAILED. Check files in dec+water
> FAILED. Check files in fe_test
> 2 out of 14 complex tests FAILED
> All 63 kernel tests PASSED
> All 45 pdb2gmx tests PASSED
> I am not very familiar with programming language C++. As I wanted to test
> also the double precision I did some changes in the gmxtest.pl file. I am
> not sure if I did it correctly. I have installed GMX with _mpi suffix, so I
> have changed the sub setup_vars section 
> sub setup_vars {
>     my $mdprefix = "";
>     if ( $parallel > 0 ) {
>         $mdprefix = "mpirun -c $parallel ";
>     }
>     if ( $double > 0 ) {
>         $grompp = "grompp_mpi";
>         $mdrun  = $mdprefix . "mdrun_mpi";
>         $ref    = "reference_d";
>     }
> and after applying command gmxtest.pl -double all I have obtained 
> sh: line 1: 30240 Segmentation fault      mdrun_mpi >mdrun.out 2>&1
> FAILED. Check files in rb1
> 1 out of 16 simple tests FAILED
> All 14 complex tests PASSED
> All 63 kernel tests PASSED
> All 45 pdb2gmx tests PASSED
> In the case of the single precision test I can not figure out the error
> since I do not have any new files produced after the test in corresponding
> directories. In the case of double precision test I have also log file in
> rb1 directory which has been terminated exactly in the same way as my
> attempts to run simulation of plate-chain system. 
> Please, could you give me some explanation and hints how to proceed further?
> It would be very helpful for me. I have checked the mailing list but did not
> find something that could help me. Thank you in advance.

Something's wrong, but you've got too many variables going on to make 
for ready diagnosis. Start with single-precision non-MPI and unmodified 
gmxtest.pl in a fresh test directory and see if that works properly. If 
not, then you have a fundamental problem. If it works, then gradually 
test a new variable until you can isolate the problem.


More information about the gromacs.org_gmx-users mailing list