[gmx-users] Selecting part of the trajectory

He, Yang yang.he at mavs.uta.edu
Mon Oct 13 17:25:11 CEST 2008

Hi all,

I am using gromacs to simulate the course grain for DNA. it is called the super-atoms including Phosphate (P),Sugar(S),Adenine base(Ab),Thymine(Tb). I have defined them in the .atp file like this,
Ab  134.1;   Adenine base
 Tb  125.1;   Thymine base
 S   83.11;   Sugar
 P   94.97;   Phosphate
But when I run this , it always shows that the atomtype "Ab" not found and  Twin-range neighbour searching (NS) with simple NS algorithm not implemented .

I wonder whether anyone of us can tell me how to slove this problems.

In addition , I wonder how I can define the potential which is not included in the gromacs.

Thank you for any suggestion.


Yang He

From: gmx-users-bounces at gromacs.org [gmx-users-bounces at gromacs.org] On Behalf Of Yang Ye [leafyoung at yahoo.com]
Sent: Monday, October 13, 2008 7:10 AM
To: Discussion list for GROMACS users
Subject: Re: [gmx-users] Selecting part of the trajectory


This is a common problem to long trajectory. It is fine as long as there is no real corruption in the trajectory file, caused by network, disk, etc.

Shift a bit backward from the -b, this may be a few hundred ps or several ns, then extract the segment you would like to have from this secondary trajectory.

Yang Ye

----- Original Message ----
From: #NGUYEN CONG TRI# <NGUY0045 at ntu.edu.sg>
To: Discussion list for GROMACS users <gmx-users at gromacs.org>
Sent: Monday, October 13, 2008 3:47:32 PM
Subject: [gmx-users] Selecting part of the trajectory

Hi all,

I want get the snapshots every 5ps of the last 1ns in a 20 ns simulation. So I want to cut out the last 1ns. I was able to do that using -b and -e flags of trjconv, say -b 19000 and -e 20000 for a .trr trajectory. However, to save disk space I converted it into .xtc format and I cannot use trjconv with -b and -e flags anymore. I got error msg like:

Fatal error:
Specified frame doesn't exist or file not seekable

One more thing, my system consists of a protein and a ligand. At some snapshots, the ligand just jumps out of the box even when I used -pbc mol -ur compact. I tried with -pbc nojump and other option as well but none works perfectly in all cases. How to make sure that the ligand always stays with the protein so that I can write the script to automatically generate the snapshots and do some post-processing on them.

Thank you for any suggestion.


More information about the gromacs.org_gmx-users mailing list