[gmx-users] segmentation fault after first header line is printed

Shan-ho Tsai shtsai at uga.edu
Fri Oct 17 22:37:20 CEST 2008


I compiled GROMACS version 4.0 on an AMD Opteron, running
Red Hat Linux (RHEL4), with the Portland Group compilers,
v. 7.2. The compilation appears to work fine, with the
following procedure:

export CPPFLAGS=-I/usr/local/fftw-3.1.2/include
export LDFLAGS=-L/usr/local/fftw-3.1.2/lib
export CC=pgcc
export F77=pgf77
export LIBS=-L/usr/X11R6/lib64

Configure with the options: 
--enable-double --enable-shared

Then I edited 1 line in the libtool file generated by 

hardcode_libdir_flag_spec="\${wl}--rpath \${wl}\$libdir"

The reason for this last step is that pgcc does not 
recognize the --rpath option. The equivalent option
is -R.


  make install

worked fine. 

Then I did

  source /usr/local/gromacs-4.0/bin/GMXRC

If I run any GROMACS binaries after this, by
calling the name itself, e.g.

   grompp_d -h

The program outputs a header line

       :-)  G  R  O  M  A  C  S  (-:

and then I get a segmentation fault. And similarly
for other commands, such as mdrun_d, pdb2gmx_d, etc.
However, if I invoke the program with the full
path, e.g.

   /usr/local/gromacs-4.0/bin/grompp_d -h

then it is fine. I did an strace on both
commands (without and with the full path)
and it appears that the segmentation fault
comes from the binary trying to open a file
whose name is my environment PATH compounded
many times until the filename is too long.

Interestingly, when I compiled gromacs with
gcc 3.4.6, both ways of invoking the binaries
(with or without the full path) work fine. 

Compilation of v.3.3.3 using the PGI compilers
resulted in the same problem (that is, invoking
a binary without the full path generates a
segmentation fault).

I would really like to use gromacs compiled with
the PGI compilers, and be able to invoke the binaries
without the full path. 

I would appreciate any ideas how to get this problem

Thank you very much,

More information about the gromacs.org_gmx-users mailing list