[gmx-users] install problems on HP-UX Itanium system

Christopher Daub cdaub at vcu.edu
Thu Sep 4 23:46:24 CEST 2008

Hello list,

I was pretty easily able to compile gromacs on a Linux cluster, but  
now I'm having some problems installing gromacs 3.3.3 on an Itanium  
computer running HP-UX 11.23.  I'm compiling without MPI for now;  
maybe later once I get it working without!

I ran ./configure after telling it where to find my FFTW, and there  
was nothing odd there except that the HP-UX C compiler doesn't like  
"+Oall" as a compiler flag, so I ran make as:

make CFLAGS="-Ae +Ofast"

or, when that didn't work, CFLAGS="-Ae +O2"; didn't seem to make much  

The errors come when compilation starts.  After a few lines I get  
stuff like:

  cc -DHAVE_CONFIG_H -I. -I../../../../src -I../../../../include - 
DGMXLIBDIR=\"/home/snoop/gmacs/share/top\" -I/home/snoop/fftw-3.1.2s/ 
include -c ia64_cpuid.S -o ia64_cpuid.o
source='nb_kernel_ia64_single.c' object='nb_kernel_ia64_single.lo'  
libtool=yes \
DEPDIR=.deps depmode=none /bin/sh ../../../../config/depcomp \
/bin/sh ../../../../libtool --tag=CC   --mode=compile cc - 
DHAVE_CONFIG_H -I. -I../../../../src  -I../../../../include - 
DGMXLIBDIR=\"/home/snoop/gmacs/share/top\" -I/home/snoop/fftw-3.1.2s/ 
include  -Ae +Ofast -c -o nb_kernel_ia64_single.lo  
  cc -DHAVE_CONFIG_H -I. -I../../../../src -I../../../../include - 
DGMXLIBDIR=\"/home/snoop/gmacs/share/top\" -I/home/snoop/fftw-3.1.2s/ 
include -Ae +Ofast -c nb_kernel_ia64_single.c -o nb_kernel_ia64_single.o
Warning 940: Unknown position # The compiler is unable to determine  
the machine
/bin/sh ../../../../libtool --tag=CC   --mode=link cc  -Ae +Ofast  -L/ 
home/snoop/fftw-3.1.2s/lib   -o libnb_kernel_ia64_single.la   
nb_kernel010_ia64_single.lo nb_kernel030_ia64_single.lo  
nb_kernel100_ia64_single.lo nb_kernel110_ia64_single.lo  
nb_kernel130_ia64_single.lo nb_kernel200_ia64_single.lo  
nb_kernel210_ia64_single.lo nb_kernel230_ia64_single.lo  
nb_kernel300_ia64_single.lo nb_kernel310_ia64_single.lo  
nb_kernel330_ia64_single.lo nb_kernel400_ia64_single.lo  
nb_kernel410_ia64_single.lo nb_kernel430_ia64_single.lo  
nb_kernel010nf_ia64_single.lo nb_kernel030nf_ia64_single.lo  
nb_kernel100nf_ia64_single.lo nb_kernel130nf_ia64_single.lo  
nb_kernel110nf_ia64_single.lo nb_kernel200nf_ia64_single.lo  
nb_kernel210nf_ia64_single.lo nb_kernel230nf_ia64_single.lo  
nb_kernel300nf_ia64_single.lo nb_kernel310nf_ia64_single.lo  
nb_kernel330nf_ia64_single.lo nb_kernel400nf_ia64_single.lo  
nb_kernel410nf_ia64_single.lo nb_kernel430nf_ia64_single.lo  
ia64_cpuid.lo nb_kernel_ia64_single.lo  -lnsl -lfftw3f -lm  -lXm - 
lXt  -lSM -lICE -lXext -lXp -lX11
mkdir .libs
ar cru .libs/libnb_kernel_ia64_single.a  nb_kernel010_ia64_single.o  
nb_kernel030_ia64_single.o nb_kernel100_ia64_single.o  
nb_kernel110_ia64_single.o nb_kernel130_ia64_single.o  
nb_kernel200_ia64_single.o nb_kernel210_ia64_single.o  
nb_kernel230_ia64_single.o nb_kernel300_ia64_single.o  
nb_kernel310_ia64_single.o nb_kernel330_ia64_single.o  
nb_kernel400_ia64_single.o nb_kernel410_ia64_single.o  
nb_kernel430_ia64_single.o nb_kernel010nf_ia64_single.o  
nb_kernel030nf_ia64_single.o nb_kernel100nf_ia64_single.o  
nb_kernel130nf_ia64_single.o nb_kernel110nf_ia64_single.o  
nb_kernel200nf_ia64_single.o nb_kernel210nf_ia64_single.o  
nb_kernel230nf_ia64_single.o nb_kernel300nf_ia64_single.o  
nb_kernel310nf_ia64_single.o nb_kernel330nf_ia64_single.o  
nb_kernel400nf_ia64_single.o nb_kernel410nf_ia64_single.o  
nb_kernel430nf_ia64_single.o ia64_cpuid.o nb_kernel_ia64_single.o
ar: could not open nb_kernel010_ia64_single.o
ar: could not open nb_kernel030_ia64_single.o
ar: could not open nb_kernel100_ia64_single.o
ar: could not open nb_kernel110_ia64_single.o
ar: could not open nb_kernel130_ia64_single.o
ar: could not open nb_kernel200_ia64_single.o
ar: could not open nb_kernel210_ia64_single.o
ar: could not open nb_kernel230_ia64_single.o
ar: could not open nb_kernel300_ia64_single.o
ar: could not open nb_kernel310_ia64_single.o
ar: could not open nb_kernel330_ia64_single.o
ar: could not open nb_kernel400_ia64_single.o
ar: could not open nb_kernel410_ia64_single.o

Somehow it's not creating the object files for the nonbonded loops.   
I naively tried simply copying all the .lo files it does create  
into .o files, that started out promisingly, but crashed with  
unsatisfied symbol errors when compiling grompp.

I also tried with --disable-ia64-asm, thinking I'd at least avoid  
these issues.  And yes, the compilation gets a fair bit further  
along, but it crashes on xutils.c:

source='xutils.c' object='xutils.o' libtool=no \
DEPDIR=.deps depmode=none /bin/sh ../../config/depcomp \
cc -DHAVE_CONFIG_H -I. -I../../src  -I../../include -DGMXLIBDIR=\"/ 
home/snoop/gmacs/share/top\" -I/home/snoop/fftw-3.1.2s/include  -Ae  
+O2 -c xutils.c
Error 187: "xutils.c", line 447 # Referenced object '_Fmax' is not a  
member of struct
     t_ffscan ["xmdrun.h", line 190].
         if ((ff.fmax == 0) || (msf1 < sqr(ff.fmax)))
gmake[3]: *** [xutils.o] Error 2

I've tried with a variety of compiler options, both make and gmake,  
etc. but so far am stumped.  These problems do not resemble any other  
problems I saw in the archive with HP-UX installations; maybe my  
setup is a bit broken? I've managed to compile other large C codes  
(eg. FFTW) with no major trouble though.

Any help would be greatly appreciated! I can send any other info  
required as requested.

Chris Daub
Virginia Commonwealth University

More information about the gromacs.org_gmx-users mailing list