[gmx-users] still some problems with HP-UX... grompp acting weird

Christopher Daub cdaub at vcu.edu
Tue Sep 9 00:25:46 CEST 2008

Hey again!

The install of gromacs 3.3.3 on HP-UX is mostly working fine, but I'm  
getting some weird behaviour from grompp where it doesn't set the  
output filename correctly.  Here is the grompp output from when I run  
the demo program, for example (the demo works fine until it gets to  
this step, after pdb2gmx and genbox):


checking input for internal consistency...
sh: /grace/bin/: Cannot create the specified file.
Cleaning up temporary file gromppa11751

Program grompp, VERSION 3.3.3
Source code file: topio.c, line: 312

Fatal error:
Could not open /grace/bin/

"If Life Seems Jolly Rotten, There's Something You've  
Forgotten !" (Monty Python

                          :-)  G  R  O  M  A  C  S  (-:

                GRoups of Organic Molecules in ACtion for Science

                             :-)  VERSION 3.3.3  (-:

       Written by David van der Spoel, Erik Lindahl, Berk Hess, and  
        Copyright (c) 1991-2000, University of Groningen, The  
              Copyright (c) 2001-2008, The GROMACS development team,
             check out http://www.gromacs.org for more information.

          This program is free software; you can redistribute it and/or
           modify it under the terms of the GNU General Public License
          as published by the Free Software Foundation; either version 2
              of the License, or (at your option) any later version.

                                 :-)  grompp  (-:

creating statusfile for 1 node...
calling /usr/bin/cpp...
cpp exit code: 256
Tried to execute: '/usr/local/bin/cpp  -I/home/snoop/gmacs/share/ 
gromacs/top -DFLEX_SP
C cpeptide.top > /grace/bin/'
The '/usr/bin/cpp' command is defined in the .mdp file
processing topology...


I think it's getting the /grace/bin thing from my PATH variable of  
all things! Why it sticks it in there as the output filename is  
beyond me.  I've looked at grompp.c and topio.c to see if I can find  
the problem, but my C coding skills are not great and I'm not sure  
what to do with all those pointers... can anyone suggest an easy fix  
for this? I tried an ugly hack to set outfile = "cppoutput" in  
topio.c, but that didn't work...

Thanks for any suggestions (other than getting rid of HP-UX...),

More information about the gromacs.org_gmx-users mailing list