[gmx-users] x2top & Encad all-atom force field (vacuum)

darrellk at ece.ubc.ca darrellk at ece.ubc.ca
Thu Apr 2 06:00:00 CEST 2009

>Date: Wed, 01 Apr 2009 22:38:28 +0200
>From: David van der Spoel <spoel at xray.bmc.uu.se>
>Subject: Re: [gmx-users] x2top & Encad all-atom force field (vacuum)
>	not	recognizing bonds
>To: Discussion list for GROMACS users <gmx-users at gromacs.org>
>Message-ID: <49D3D0C4.4040206 at xray.bmc.uu.se>
>Content-Type: text/plain; charset=ISO-8859-1; format=flowed
>darrellk at ece.ubc.ca wrote:
>> Dear All,
>> I have been trying to determine why I am experiencing problems when I run
>> a gromacs file through x2top. I have checked my gromacs file with VMD to
>> ensure that the file is correct and VMD validates that my file is
>> correct as I see the intended structure. Thus, the atoms are indeed
>> located within reasonable distance from each other such that x2top
>> should be recognizing the bonds.
>> Here is an extract from my gromacs file:
>>     2Grph C        1   0.000   0.000   0.000  0.0000  0.0000  0.0000
>>     2Grph C        2   0.071  -0.123   0.000  0.0000  0.0000  0.0000
>>     2Grph C        3   0.071   0.123   0.000  0.0000  0.0000  0.0000
>>     2Grph C        4  -0.142   0.000   0.000  0.0000  0.0000  0.0000
>>     2Grph C        5  -0.000  -0.250   0.000  0.0000  0.0000  0.0000
>>     2Grph C        6   0.210  -0.120   0.000  0.0000  0.0000  0.0000
>> I thought that in order to make x2top work correctly that I would have to
>> modify the files as described in Christopher Stiles website
>> (http://cs86.com/CNSE/SWNT.htm). I made the specified changes to the
>> following files and saved them in my working directory:
>> ffencadv.n2t
>> ffgmx.n2t
>> ffgmxbon.itp
>> I also changed the name of ffgmxbon.itp to ffencadvbon.itp as I read in
>> one post that this file should be renamed as such.
>> After all these changes, I still experience a problem when I run the
>> command:
>> x2top -ff select -f graphene_nm.gro -o graphene_nm.top
>> selecting option  7: Encad all-atom force field, using scaled-down vacuum
>> charges
>> When I run the above command, I receive output telling me that the atoms
>> have 0 bonds. An extract of the output appears below for your reference.
>> Can not find forcefield for atom H-266 with 0 bonds
>> Can not find forcefield for atom H-267 with 0 bonds
>> Can not find forcefield for atom H-268 with 0 bonds
>> Can not find forcefield for atom H-269 with 0 bonds
>> Can not find forcefield for atom H-270 with 0 bonds
>Could there still be an error in your  gro file, as it seems to contain
>only C, and the error message points to H. x2top might work slightly
>better in 4.0.x. And by the way, this tutorial may be slightly
>confusing. The only thing you need to do is edit the .n2t file
>corresponding to your force field. I don't recall what is supplied in
>3.3, but in 4.0 it is ffoplsaa.n2t.

My gro file does contain H atoms as well. In my extract of the gro file I
only showed the first few lines of the gro file and these lines only
have C atoms. Note that I receive the same message for the C atoms (i.e.
"Can not find forcefield for atom C-1 with 0 bonds").

I actually created the files ffencadv.n2t & ffgmx.n2t in my working
directory since the only n2t file I could find in the gromacs directory
was the ffoplsaa.n2t file and the tutorial did not mention the
ffoplsaa.n2t file. Should I be modifying the ffoplsaa.n2t file instead?
If so, can you please provide me some direction on what needs to be
added to this file so that it recognizes the atoms in my graphene
structure as I looked at this file but do not understand what some of
the columns represent.

Also, I thought that ffoplsaa was to be used for liquids and since my
simulation is in an air environment, I thought that I should be using
the encad force field in a vacuum and should therefore be modifying an
encad n2t file. Please correct me if I am wrong.

Also, could you also please explain the purpose of the n2t file as I
looked in the gromacs manual and see no description of files with the
n2t extension and their purpose.

Thanks again in advance.


>> -------------------------------------------------------
>> Program x2top, VERSION 3.3.3
>> Source code file: x2top.c, line: 206
>> Fatal error:
>> Could only find a forcefield type for 0 out of 270 atoms
>> -------------------------------------------------------
>> Could you please help me resolve this issue?
>> Thank you in advance for your assistance.
>> Darrell Koskinen
>> _______________________________________________
>> gmx-users mailing list    gmx-users at gromacs.org
>> http://www.gromacs.org/mailman/listinfo/gmx-users
>> Please search the archive at http://www.gromacs.org/search before posting!
>> Please don't post (un)subscribe requests to the list. Use the
>> www interface or send it to gmx-users-request at gromacs.org.
>> Can't post? Read http://www.gromacs.org/mailing_lists/users.php
>David van der Spoel, PhD, Professor of Biology
>Dept. of Cell and Molecular Biology, Uppsala University.
>Husargatan 3, Box 596,  	75124 Uppsala, Sweden
>phone:	46 18 471 4205		fax: 46 18 511 755
>spoel at xray.bmc.uu.se	spoel at gromacs.org   http://folding.bmc.uu.se

More information about the gromacs.org_gmx-users mailing list