[gmx-users] Problems with Jacobi diagonalization

Justin A. Lemkul jalemkul at vt.edu
Sat Apr 11 01:10:39 CEST 2009

Dayle Smith wrote:
> Thanks for your help, Justin. I ran gmxcheck -c topol.tpr ("12284 atoms 
> in file") and gmxcheck -f traj.xtc ("# Atoms  29"). The difference is 
> the SOL atoms. I made another .tpr file with xtcgroups = TDR SOL, and 
> now gmxcheck shows that the number of atoms in topol.tpr is 12284, but I 
> still can't get g_covar to work. Maybe these are unrelated problems, I'm 
> not sure.

If you specify xtc-grps, that is what is saved in the simulation; it has no 
effect on the coordinates processed by grompp.  If you are using a .pdb or .gro 
file as input into grompp that has both SOL and TDR, then you will *always* have 
those atoms in the .tpr file.  Changes to the .mdp file have no impact 
whatsoever on the coordinate contents of the .tpr file.

There are two potential solutions, and the only way to solve your issue will be 
to do one of the following:

1. Use tpbconv to create a new .tpr file with only TDR (select TDR as the output 
group when prompted)
2. Strip your coordinate file of water and re-process with grompp, such that 
grompp is only interpreting the coordinates of TDR

Option #1 is simpler; option #2 is instructive in terms of understanding how the 
.tpr file is assembled and how coordinates are interpreted.


> ~Dayle
> On Wed, Apr 1, 2009 at 2:49 PM, Justin A. Lemkul <jalemkul at vt.edu 
> <mailto:jalemkul at vt.edu>> wrote:
>     Dayle Smith wrote:
>         Hi Tsjerk,
>         Thank you for your quick and helpful response. I defined
>         "xtc_grps  = TDR" in my .mdp file (then I use grompp -f
>         mdpme.mdp -c confout.gro -p topol.top -o topol.tpr -np 8 -n
>         index.ndx, index contains TDR and SOL) and run it with -np 8.
>         I'm afraid that I don't understand what "shuffling" or "matching
>         series" refers to (a clue that I'm doing something wrong).  This
>         g_covar error message is probably another clue:
>         WARNING: number of atoms in tpx (29) and trajectory (29) do not
>         match
>         -------------------------------------------------------
>         Program g_covar, VERSION 3.3.3
>         Source code file: nrjac.c, line: 129
>         Fatal error:
>         Error: Too many iterations in routine JACOBI
>         So the # of atoms is the same, but some other key ingredient
>         doesn't match. Can you please enlighten me?!
>     I think the output error message is bizarre, but you still have a
>     number of atoms in the .tpr that does not match the .xtc.  If your
>     simulation is of TDR and SOL, then those groups will be in your
>     topol.tpr.  If your xtc-grps specify only TDR, then there will be a
>     coordinate mismatch.  Run the following:
>     gmxcheck -c topol.tpr
>     gmxcheck -f traj.xtc
>     and see if gmxcheck reports the same number of atoms in both files.
>      This is the quickest way to know for sure.
>     -Justin
>         Thanks a lot,
>         Dayle
>         On Wed, Apr 1, 2009 at 11:12 AM, Tsjerk Wassenaar
>         <tsjerkw at gmail.com <mailto:tsjerkw at gmail.com>
>         <mailto:tsjerkw at gmail.com <mailto:tsjerkw at gmail.com>>> wrote:
>            Hi Dayle,
>            Errm, really, the only cases I know of this error to occur is
>         when I
>            had a mismatch between the reference and trajectory. Did you
>         specify
>            xtc-groups? Did you shuffle the system? How did you assert
>         that you
>            have matching series? Have you tried using the reference and the
>            trajectory to convert (part of) the trajectory to .pdb and
>         visualize?
>            If all else fails, can you send (a link to) an archive
>         containing a
>            single frame from the trajectory and the reference?
>            Cheers,
>            Tsjerk
>            2009/4/1 Dayle Smith <daylemariesmith at gmail.com
>         <mailto:daylemariesmith at gmail.com>
>            <mailto:daylemariesmith at gmail.com
>         <mailto:daylemariesmith at gmail.com>>>:
>             > Greetings---
>             > I'm working with a DNA system, and all of the routines I've
>            worked with that
>             > require Jacobi diagonalization (g_covar, g_rms, etc) fail with
>            the "Too many
>             > iterations in routine JACOBI" error. I'm using
>         gromacs-3.3.3 with
>            ffamber99
>             > on the NCSA Mercury cluster. I've searched the archives,
>         and I've
>            found
>             > several entries in which users are advised to check that the
>            coordinates in
>             > the trajectory and structure files match (mine do). I've also
>            tried running
>             > covariance analysis on a small ligand molecule, and I get the
>            same error. I
>             > can get g_covar to work with -nofit, but then I can't run
>         g_anaeig.
>             >
>             > I'm eagerly looking forward to your suggestions!
>             >
>             > Have a great day,
>             > Dayle Smith
>             > Department of Physics
>             > Whitman College
>             >


Justin A. Lemkul
Graduate Research Assistant
ICTAS Doctoral Scholar
Department of Biochemistry
Virginia Tech
Blacksburg, VA
jalemkul[at]vt.edu | (540) 231-9080


More information about the gromacs.org_gmx-users mailing list