[gmx-users] Problem configuring openMPI

Manik Mayur manik.mayur at gmail.com
Tue Mar 3 16:29:10 CET 2009


I have till now successfully used openMPI and gromacs together. Recently I
got a cluster where I tried to install openMPI and gromacs locally as I
donot have root priviledges on it. But it turns out that it already has MPI
environment on it (LAM) which I donot want to use (as the version is quite
old.. the cluster still has gcc-3.2.3!).
So after installing openMPI 1.3 and gromacs 4.0.4 on it (in my /home
folder), I tried to execute:

$/home/openmpi/bin/mpirun -np 4 mdrun_4_mpi -s eql_mpi.tpr -o eql_mpi.trr

It gives the following error:

It seems that there is no lamd running on this host, which indicates
that the LAM/MPI runtime environment is not operating.  The LAM/MPI
runtime environment is necessary for MPI programs to run (the MPI
program tired to invoke the "MPI_Init" function).

Please run the "lamboot" command the start the LAM/MPI runtime
environment.  See the LAM/MPI documentation for how to invoke
"lamboot" across multiple machines.

My question is - Why it still tries to look for LAM environment or lamd? I
will be extremely thankful if somebody gives a hint.

Graduate student
Microfluidics Lab
Dept. of Mechanical Engg.
IIT Kharagpur
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://maillist.sys.kth.se/pipermail/gromacs.org_gmx-users/attachments/20090303/5cdcd855/attachment.html>

More information about the gromacs.org_gmx-users mailing list