[gmx-users] RE: Question for pulling in GROMACS 4.0

Thomas Schlesier schlesi at uni-mainz.de
Wed Mar 25 18:59:31 CET 2009

First of all it's best to post the error-message (i think there must be one).
>From the pulling options below i would say the problem is probably that you have 'pull_dim' and 'pull_geometry = direction', manual say 'pull_dim' is for 'distance' and 'position'. Another think is that you have in 'pull_vec1' 3 dimensions and in 'pull_init1' only one, this could be the problem when you used 'pull_geometry = position'. The last idea i have is this: 'pull_kB1 = 500'. The manual states that this is only for the free-energy-code.
But this are only guesses, because we have no error-message and i have only used 'pull_dim = Y Y Y' with 'pull_geometry = position' (and that only once to try it out).

Below are the options which i used (GROMACS 4.0.2) (the velocity and the force-constant are so high, that i see something in little time).
REF and ZUG are single atoms, and the two vectors (pull_vec1, pull_init1) are the vector from REF to ZUG. I tried it also with 'pull_start = yes' and 'pull_init1 = 0.0 0.0 0.0' and it worked.
But i never tried the other 'pull_geometry'-options.

; Pulling
pull                =  umbrella
pull_geometry       =  position
pull_dim            =  Y Y Y
pull_start          =  no
pull_nstxout        =  10
pull_nstfout        =  10
pull_ngroups        =  1
pull_group0         =  REF
pull_group1         =  ZUG
pull_vec1           =  -0.012 -0.174 1.794
pull_init1          =  -0.012 -0.174 1.794
pull_rate1          =  0.01
pull_k1             =  5000

Hope this helps


Dear Thomas,
I took you name from the gromacs mail list. It seems that you have been successful using the pulling in the new gromacs version.
I used the 3.3 version for simulating afm pulling but I could not do it with the new code.

All I want to do is constant velocity pulling group r_76 in the Z direction.
I tried pulling r_1 to 001 and r_76 00-1 using the option for pull_ngroups =2, tried pull_geometry = position and nothing worked.
It's a simple protein with 76 residues and solvated in water. I am attaching at the end of the message my last try of pulling options
I really appreciate any suggestion you may have on this matter.
Marisa Roman
Physics Dept.
Drexel University, Philadelphia

pull = umbrella
pull_geometry = direction
pull_start = yes
pull_ngroups = 1
pull_group0 = r_1
pull_group1 = r_76
pull_dim = N N Y
pull_start = yes
pull_k1 = 500
pull_kB1 = 500
pull_rate1 = 0.05
pull_vec1 = 0 0 1
pull_init1 = 0.0
pull_nstxout = 100
pull_nstfout = 100


More information about the gromacs.org_gmx-users mailing list